Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
OD receiver 5.0.1 as non root user
eryoni
We are trying to start/stop Open Deploy Receiver (v5.0.1) as non root user but we are getting the following errors in odrcvr.log:
API: 2003-12-19 17:09:47 CET Starting OpenDeploy server.
ENG: 2003-12-19 17:09:47 CET ***ERROR - Exception: CONFIG_FILE.
message: CONFIG_FILE.
Details: File not found
at com.interwoven.deploy.adapters.od.TNewToOldRx.convert(TNewToOldRx.java:93)
at com.interwoven.deploy.adapters.od.TNewToOldRx.convert(TNewToOldRx.java:58)
at com.interwoven.deploy.engine.TMacroDeployReceiver.start(TMacroDeployReceiver.java:121)
at com.interwoven.deploy.engine.TDeploySvrEngine.start(TDeploySvrEngine.java:692)
at com.interwoven.deployapi.deploy.IWDeployServiceRemoterImpl.<init>(IWDeployServiceRemoterImpl.java:662)
at java.lang.reflect.Constructor.newInstance(Native Method)
at com.interwoven.deployapi.service.IWODServiceServer.startService(IWODServiceServer.java:373)
at com.interwoven.deployapi.service.IWODServiceServer.startServiceList(IWODServiceServer.java:296)
at com.interwoven.deployapi.service.IWODServiceServer.server(IWODServiceServer.java:158)
at com.interwoven.deployapi.service.IWODServiceServer.main(IWODServiceServer.java:169)
at java.lang.reflect.Method.invoke(Native Method)
at com.zerog.lax.LAX.a([DashoPro-V1.2-120198])
at com.zerog.lax.LAX.main([DashoPro-V1.2-120198])
API: 2003-12-19 17:09:47 CET *** ERROR: OpenDeploy server encountered error.
Bring up of OpenDeploy server FAILED.
message: AGENT_RECEIVER_FAILED
Details: Failed to start OpenDeploy receiver.error caught:
CONFIG_FILE.
at com.interwoven.deploy.engine.TMacroDeployReceiver.start(TMacroDeployReceiver.java:145)
at com.interwoven.deploy.engine.TDeploySvrEngine.start(TDeploySvrEngine.java:692)
at com.interwoven.deployapi.deploy.IWDeployServiceRemoterImpl.<init>(IWDeployServiceRemoterImpl.java:662)
at java.lang.reflect.Constructor.newInstance(Native Method)
at com.interwoven.deployapi.service.IWODServiceServer.startService(IWODServiceServer.java:373)
at com.interwoven.deployapi.service.IWODServiceServer.startServiceList(IWODServiceServer.java:296)
at com.interwoven.deployapi.service.IWODServiceServer.server(IWODServiceServer.java:158)
at com.interwoven.deployapi.service.IWODServiceServer.main(IWODServiceServer.java:169)
at java.lang.reflect.Method.invoke(Native Method)
at com.zerog.lax.LAX.a([DashoPro-V1.2-120198])
at com.zerog.lax.LAX.main([DashoPro-V1.2-120198])
Does anybody know how to deal with this issue?.
Thanks in advance
Find more posts tagged with
Comments
Bubas_IWOV
Hi,
In the version 5.6 if you look at the latest version of the admin manual, you will find some info how to do it in that version. Why not give a try and see if it works in you version of the receiver.
Regards
Bruno
eryoni
It would be great if we had the iwodnonroot script on version 5.0.1, but we haven't. :-(
So, the question is: which files are needed to change permissions in order to run OD receiver as non root?
Other posibility: Is OD receiver version 5.6 compliant with the old versions in order to upgrade only the receiver on our site?
Thanks a lot
Migrateduser
Running OD 5.0.1 as non-root isn't supported.
OD 5.6 has a tool called iwodnonroot, which will take care of setting up non-root operation.
OD 5.6 is capable of deploying to targets running OD 5.0.1. So, although you would have to upgrade both your sender and receiver to 5.6, other receivers you might have that run as root can remain at the 5.0.1 version.
Todd Scallan
Director of Product Management
Interwoven
t: 408-530-7167
e:
tscallan@interwoven.com