Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
opendeploy version error
diago
using Opendeploy 5.6.0.1.0 Build 28338 Interwoven 20031124 both on source and destination
when I lanch iwodcmd start test.xml I have the following message in log
LIB: 2004-03-25 09:36:23 ERROR: Connection failed: Could not find matching OpenDeploy client for (source).
any hints ?
Find more posts tagged with
Comments
Adam Stoller
We'd need to see the config files (server configs and deployment config) and probably log files, in order to have a hope of helping you here.
Shooting in the dark: You don't have the receiver configured to accept deployments from the sender - or at least not properly.
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com
diago
here are the odnodes files identical on both servers
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<nodeSet>
<node name="source"
host="10.80.52.248"
port="20014"
/>
<node name="destination"
host="10.80.52.247"
port="20014"
/>
</nodeSet>
here are the deployement file
<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<deploymentConfiguration>
<logRules maxBytes="32Mb" level="verbose"/>
<localNode host="source"/>
<replicationFarmSet>
<replicationFarm name="MYFARMNAME">
<nodeRef useNode="destination"/>
</replicationFarm>
</replicationFarmSet>
<definition name="MYDEFINITIONNAME">
<source>
<sourceFilesystem area="/exploit/IW/od-home/OpenDeployNG/conf/dtd">
<pathSpecification>
<path name="."/>
</pathSpecification>
</sourceFilesystem>
</source>
<target useReplicationFarm="MYFARMNAME">
<targetFilesystem area="/exploit/IW/od-home/OpenDeployNG/tmp"/>
<comparisonRules dateDifferent="yes"/>
<permissionRules file="0644" directory="0755"/>
</target>
</definition>
<deployment transactional="no">
<execDeploymentTask useDefinition="MYDEFINITIONNAME"/>
</deployment>
</deploymentConfiguration>
here are the log
ENG: 2004-03-25 15:49:53 WET GMT+00:00 Thread-17 Begin logfile [/exploit/IW/od-home/OpenDeployNG/log/src.testOD.MYDEFINITIONNAME.source.to.destination.log] ---------
ENG: 2004-03-25 15:49:53 WET GMT+00:00 Thread-17 Job ID=m3 Deployment=testOD
ENG: 2004-03-25 15:49:53 WET GMT+00:00 Thread-17 OpenDeploy Version is 5.6.0.1.0
ENG: 2004-03-25 15:49:53 WET GMT+00:00 Thread-17 Owner started the deployment is root
ENG: 2004-03-25 15:49:53 WET GMT+00:00 Thread-17 Internal config file [/exploit/IW/od-home/OpenDeployNG/etc/.testOD.MYDEFINITIONNAME.destination]
ENG: 2004-03-25 15:49:53 WET GMT+00:00 -------------------------------------------------
deployment_name=.testOD.MYDEFINITIONNAME.destination
hostname=normandie
remote_server=10.80.52.247
remote_port=20014
buffer_size=8000
verbose_level=5
do_manifest_for_dnr
do_manifest_for_events
deployment=.testOD.MYDEFINITIONNAME.destination
area=/exploit/IW/od-home/OpenDeployNG/conf/dtd
local_directory=.
dir_perm=0755
file_perm=0644
date_different
ignore_acls
remote_directory=/exploit/IW/od-home/OpenDeployNG/tmp
;
;
ENG: 2004-03-25 15:49:53 WET GMT+00:00 -------------------------------------------------
ENG: 2004-03-25 15:49:53 WET GMT+00:00 Thread-17 End of internal config file [/exploit/IW/od-home/OpenDeployNG/etc/.testOD.MYDEFINITIONN
AME.destination]
ENG: 2004-03-25 15:49:53 WET GMT+00:00 Thread-17 exiting initial
ENG: 2004-03-25 15:49:53 WET GMT+00:00 Thread-17 entering setup
LIB: 2004-03-25 15:49:53 LOGFILE=[/exploit/IW/od-home/OpenDeployNG/log/src.testOD.MYDEFINITIONNAME.source.to.destination.log]
LIB: 2004-03-25 15:49:53 Locale=[English_UnitedStates.US-ASCII@Binary]
ENG: 2004-03-25 15:49:53 WET GMT+00:00 Thread-17 Connecting to host=10.80.52.247 port=20014
ENG: 2004-03-25 15:49:53 WET GMT+00:00 Thread-17Sender Side timeout0
ENG: 2004-03-25 15:49:53 WET GMT+00:00 Thread-17 After Connect RC = 0
ENG: 2004-03-25 15:49:53 WET GMT+00:00 Thread-17 Sender-side handshake timeout = 120 secs
ENG: 2004-03-25 15:49:53 WET GMT+00:00 Thread-17 Send version string to receiver, RC = 13
ENG: 2004-03-25 15:50:02 WET GMT+00:00 Thread-17 Send attributes to receiver, RC = 1
ENG: 2004-03-25 15:50:02 WET GMT+00:00 Thread-17 Read attributes from receiver.
ENG: 2004-03-25 15:50:02 WET GMT+00:00 Thread-17 sender-version=5.6.0.1.0 receiver-version=5.6.0.1.0
ENG: 2004-03-25 15:50:02 WET GMT+00:00 Thread-17 Sender is version master
ENG: 2004-03-25 15:50:02 WET GMT+00:00 Thread-17 Sender compatible with receiver: version same
ENG: 2004-03-25 15:50:03 WET GMT+00:00 Thread-17 Sender profile
#session properties
#Thu Mar 25 15:49:53 WET 2004
TARGETAREA=/exploit/IW/od-home/OpenDeployNG/tmp
ODADAPTERSET=
DEPLOYNAME=testOD
DEPUUID=testOD.m3.Thu_Mar_25_15\:49\:53_WET_2004
JOBID=m3
DEFNAME=MYDEFINITIONNAME
DEPLOYTYPE=103
DESCRIPTION=
DEPLOYSUFFIX=
OWNER=root
SYNCHRONIZEPHASE=false
SOURCEHOST=source
TRANSACTIONAL=false
COMPRESSION=false
VERSION=5.6.0.1.0
LEGID=destination
TARGHOST=10.80.52.247
SYNCH=true
VERIFYPHASE=false
REVERSE=false
LOGLEVEL=VERBOSE
LIB: 2004-03-25 15:50:03 LOGFILE=[/exploit/IW/od-home/OpenDeployNG/log/src.testOD.MYDEFINITIONNAME.source.to.destination.log]
LIB: 2004-03-25 15:50:03 Locale=[English_UnitedStates.US-ASCII@Binary]
LIB: 2004-03-25 15:50:03 Interwoven OpenDeploy(5.6.0.1.0 Build 21220 Interwoven 20030618)
LIB: 2004-03-25 15:50:03 LIB: Component Version (5.6.0.1.0 Build 28338 Interwoven 20031124)
LIB: 2004-03-25 15:50:03 Buffer Size (8000)
LIB: 2004-03-25 15:50:03 Protocol Version(5.0) OK
LIB: 2004-03-25 15:50:03 Connection Id(id=0)
LIB: 2004-03-25 15:50:03 Transaction Mode: OFF
LIB: 2004-03-25 15:50:03 Mode(normal)
LIB: 2004-03-25 15:50:03 Protocol(normal)
LIB: 2004-03-25 15:50:03 Hostname(source)
LIB: 2004-03-25 15:50:03 ERROR: Connection failed: Could not find matching OpenDeploy client for (source).
ENG: 2004-03-25 15:50:03 WET GMT+00:00 Thread-17 After SETUP, res=-1
ENG: 2004-03-25 15:50:03 WET GMT+00:00 Thread-17 exiting setup
ENG: 2004-03-25 15:50:03 WET GMT+00:00 Thread-17 entering awaiting-cleanup
ENG: 2004-03-25 15:50:03 WET GMT+00:00 Thread-17 exiting awaiting-cleanup
ENG: 2004-03-25 15:50:03 WET GMT+00:00 Thread-17 entering cleanup
ENG: 2004-03-25 15:50:03 WET GMT+00:00 Thread-17 After CLEANUP, res=-1
ENG: 2004-03-25 15:50:03 WET GMT+00:00 Thread-17 exiting cleanup
ENG: 2004-03-25 15:50:03 WET GMT+00:00 Thread-17 entering task-failed
ENG: 2004-03-25 15:50:03 WET GMT+00:00 Thread-17 still waiting for 0
LIB: 2004-03-25 15:50:03 LOGFILE=[/exploit/IW/od-home/OpenDeployNG/log/src.testOD.MYDEFINITIONNAME.source.to.destination.log]
LIB: 2004-03-25 15:50:03 Locale=[English_UnitedStates.US-ASCII@Binary]
ENG: 2004-03-25 15:50:03 WET GMT+00:00 Thread-17 PostDisConnect Dnr still waiting for 0
ENG: 2004-03-25 15:50:03 WET GMT+00:00 Thread-17 Deleting the internal config file = /exploit/IW/od-home/OpenDeployNG/etc/.testOD.MYDEFI
NITIONNAME.destination
ENG: 2004-03-25 15:50:03 WET GMT+00:00 Thread-17 ***ERROR - I/O error with [/exploit/IW/od-home/OpenDeployNG/log/src.testOD.MYDEFINITIO
NNAME.source.to.destination.log.mf]: File not found
ENG: 2004-03-25 15:50:03 WET GMT+00:00 Published leg event depUuid=[testOD.m3.Thu_Mar_25_15:49:53_WET_2004] legLabel=[destination.MYDEFINIT
IONNAME] nextUuid=[null] nextDep=[null]
ENG: 2004-03-25 15:50:03 WET GMT+00:00 Thread-17 Job ID=m3 Deployment leg=destination.MYDEFINITIONNAME Elapsed Time=10120 ms <<<
ENG: 2004-03-25 15:50:03 WET GMT+00:00 Thread-17 End logfile [/exploit/IW/od-home/OpenDeployNG/log/src.testOD.MYDEFINITIONNAME.source.to.destination.log]
regards,
Eric Grandjean
Adam Stoller
Off the bat - localNode's attribute is not looked up in the odnodes.xml file - however, OD does [currently] allow you to put any string there as long as the receiver's configuration file (which you didn't supply) clearly shows the same string within the allowedHosts section.
My guess is that you do not have "source" listed as an allowedHost on the Receiver and/or if you do, that you didn't restart the receiver after making that change, so it didn't take effect.
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com
diago
the odnodes file is the the same for the source and destination server and I actually restart OpenDeploy both on the source and destination servers after modifications in odnodes.cfg file
Adam Stoller
You're missing a few points here.
(1) odnodes.xml is NOT used by the Receiver - it is ONLY used by the Base Server
(2) value of the host attribute in the localNode element in your deployment configuration file MUST match a host attribute in the node element within the allowedHosts element in your odrcvr.xml file in order to allow the deployment to go through
(3) the target path specified for the deployment must also be listed within the allowedDirectories section associated with that allowed host in the odrcvr.xml file.
You keep talking about odnodes.xml - I'm talking about odrcvr.xml
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com
diago
Hi
you're right I completed the allowedhost section both in odrcv.xml and odbase.xml and it works
Thanks