Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
OpenDeploy 5.6 SP1 Failure - Manifest file missing
fkloong
Hi ,
When doing the deployment of file using OpenDeploy 5.6SP1, encounter the following error:
LIB: 2004-03-23 14:40:15 LOGFILE=[C:\iw-home\OpenDeployNG\log\src.metadata_deployooo.third-deploy.cisdcms1.to.cisdden1.log]
LIB: 2004-03-23 14:40:15 Locale=[English_UnitedStates.MS1252@Binary]
LIB: 2004-03-23 14:40:15 ERROR: TMP directory is invalid
ENG: 2004-03-23 14:40:15 SGT GMT+08:00 Thread-28 After SETUP, res=-1
ENG: 2004-03-23 14:40:15 SGT GMT+08:00 Thread-28 exiting setup
ENG: 2004-03-23 14:40:15 SGT GMT+08:00 Thread-28 entering awaiting-cleanup
ENG: 2004-03-23 14:40:15 SGT GMT+08:00 Thread-28 still waiting for 1
ENG: 2004-03-23 14:40:15 SGT GMT+08:00 Thread-28 exiting awaiting-cleanup
ENG: 2004-03-23 14:40:15 SGT GMT+08:00 Thread-28 entering cleanup
ENG: 2004-03-23 14:40:15 SGT GMT+08:00 Thread-28 After CLEANUP, res=-1
ENG: 2004-03-23 14:40:0015 SGT GMT+08:00 Thread-28 exiting cleanup
ENG: 2004-03-23 14:40:15 SGT GMT+08:00 Thread-28 entering task-failed
ENG: 2004-03-23 14:40:15 SGT GMT+08:00 Thread-28 still waiting for 1
LIB: 2004-03-23 14:40:15 LOGFILE=[C:\iw-home\OpenDeployNG\log\src.metadata_deployooo.third-deploy.cisdcms1.to.cisdden1.log]
LIB: 2004-03-23 14:40:15 Locale=[English_UnitedStates.MS1252@Binary]
ENG: 2004-03-23 14:40:16 SGT GMT+08:00 Thread-28 PostDisConnect Dnr still waiting for 0
ENG: 2004-03-23 14:40:16 SGT GMT+08:00 Thread-28 Deleting the internal config file = C:\iw-home\OPENDE~1\etc\.metadata_deployooo.third-deploy.cisdden1
ENG: 2004-03-23 14:40:16 SGT GMT+08:00 Thread-28 ***ERROR - I/O error with [C:\iw-home\OpenDeployNG\log\src.metadata_deployooo.third-deploy.cisdcms1.to.cisdden1.log.mf]: File not found
ENG: 2004-03-23 14:40:16 SGT GMT+08:00 TEventReportingException: com.interwoven.report100.TPublisherNotFoundException
It said in the log file that the Manifest file wasn't created. Anyone have any idea?
Below is the current system :
OS : Windows 2000 SP3
TeamSite 5.5.2 SP4
OpenDeploy 5.6 SP1 Build 28338
Thanks.
Best Regards,
Fan Kim Loong
Find more posts tagged with
Comments
Migrateduser
I suspect the root cause of the error is
LIB: 2004-03-23 14:40:15 ERROR: TMP directory is invalid
TMP should be a system-wide variable on your Windows server that points to an existing directory into which the OD process is authorized to read and write.
Todd Scallan
Director of Product Management
Interwoven
t: 408-530-7167
e:
tscallan@interwoven.com
fkloong
Hi Todd,
Thank for the reply. I already set the system's TMP variable to point to C:\Tmp folder but i am still experiencing the same problem. One of my colleague found out that the problem of this is related to the OD services . We change the Logon User of the OD service in Windows 2000 to use another Super User, it solved the problem. My question is , why is it required specific log-on user instead of using LocalSystem to start the Opendeploy service?
Thanks.
Best Regards,
Fan Kim Loong
Migrateduser
The OD service can typically run as any user on a Windows system, provided that user has authorization to access all the necessary directories and files.
Todd Scallan
Director of Product Management
Interwoven
t: 408-530-7167
e:
tscallan@interwoven.com
JonathonG
I would speculate that TMP is not defined as a SYSTEM env. var, but instead is defined as a USER env. var. Either that, or, since you added it as a SYSTEM var, you have not re-started the system. IIRC, Windows doesn't supply new SYSTEM env. vars to processes until after a reboot.
Jonathon
Independent Interwoven Contractor
Ottawa_IWOV
I am having this problem as well. I made the TMP and TEMP variables point to
\TEMP respectively. Not sure what else to do on this one. Here is the log output I am getting:
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Thread-18 Block max wait time (sec): 1800
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Thread-18 Block check interval (sec): 30
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Thread-18 Remote side has path registry disabled
LIB: 2005-03-03 14:18:13 LOGFILE=[D:\PROGRA~1\INTERW~1\OPENDE~1\log\src.refreshIndex.Definition1.lbpdmkwm05.to.verityindex.log]
LIB: 2005-03-03 14:18:13 Locale=[English_UnitedStates.MS1252@Binary]
LIB: 2005-03-03 14:18:13 Interwoven OpenDeploy(6.0.1.0.0 Build 41860 Interwoven 20041018)
LIB: 2005-03-03 14:18:13 LIB: Component Version (6.0.1.0.0 Build 41860 Interwoven 20041018)
LIB: 2005-03-03 14:18:13 Buffer Size (8000)
LIB: 2005-03-03 14:18:13 Protocol Version(5.0) OK
LIB: 2005-03-03 14:18:13 Connection Id(id=m3)
LIB: 2005-03-03 14:18:13 Transaction Mode: OFF
LIB: 2005-03-03 14:18:13 Mode(normal)
LIB: 2005-03-03 14:18:13 Protocol(normal)
LIB: 2005-03-03 14:18:13 Hostname(LBPDMKWM05)
LIB: 2005-03-03 14:18:13 ERROR: Connection failed: Could not find matching OpenDeploy client for (LBPDMKWM05).
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Thread-18 After SETUP, res=-1
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Thread-18 exiting setup
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Thread-18 entering awaiting-cleanup
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Thread-18 exiting awaiting-cleanup
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Thread-18 entering cleanup
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Thread-18 After CLEANUP, res=-1
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Thread-18 exiting cleanup
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Thread-18 entering task-failed
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Thread-18 still waiting for 0
LIB: 2005-03-03 14:18:13 LOGFILE=[D:\PROGRA~1\INTERW~1\OPENDE~1\log\src.refreshIndex.Definition1.lbpdmkwm05.to.verityindex.log]
LIB: 2005-03-03 14:18:13 Locale=[English_UnitedStates.MS1252@Binary]
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Thread-18 PostDisConnect Dnr still waiting for 0
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Thread-18 Deleting the internal config file =
\PROGRA~1\INTERW~1\OPENDE~1\log\.refreshIndex.Definition1.verityindex
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Thread-18 ***ERROR - I/O error with [D:\PROGRA~1\INTERW~1\OPENDE~1\log\src.refreshIndex.Definition1.lbpdmkwm05.to.verityindex.log.mf]: File not found
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Published leg event depUuid=[fce12ea0-8c18-11d9-b66e-d9cef531e7b2] legLabel=[verityindex.Definition1] nextUuid=[null] nextDep=[null]
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Thread-18 Job ID=m3 Deployment leg=verityindex.Definition1 Elapsed Time=49 ms <<<
ENG: 2005-03-03 14:18:13 EST GMT-05:00 Thread-18 End logfile [D:\PROGRA~1\INTERW~1\OPENDE~1\log\src.refreshIndex.Definition1.lbpdmkwm05.to.verityindex.log]
Our platform is Windows 2003 EE, TeamSite 6.5, Open Deploy 6.0
Edited by Ottawa_IWOV on 03/03/05 11:23 AM (server time).
John742
"ERROR: Connection failed: Could not find matching OpenDeploy client for (LBPDMKWM05)."
Check your odnodes file against what you have set in your .xml file (the file not found error is a result of this)
J Dagenhardt
Adam Stoller
"ERROR: Connection failed: Could not find matching OpenDeploy client for (LBPDMKWM05)."
Check your odnodes file against what you have set in your .xml file (the file not found error is a result of this)
J Dagenhardt
you also might want to check the
odrcvr.xml
(or
odbase.xml
if the target machine is a base server) and verify that you have LBPDMKWM05 listed as an
allowedHost
-- and if you do, whether you've restarted that receiver since that change was made?
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com