Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Cannot preview ASP in TS 6.1 SP1
bpg
good morning,
ive recently built a clean install of TS 6.1 SP1 (patches included) on a fully patched W2003 EE OS. i have an existing production install of 5.5.2 SP6 on W2K SP4 and have been attempting to migrate the install from one to the other. so far, this has been going pretty smoothly, expect for the fact that i cannot resolve this problem where ASP cannot be previewed or generated in CC Pro. HTML is fine. ive meticulously merged all the customisation files from the 5.5.2 to the 6.1 and after some initial teething problems, it seems to like the templating side of things.
ive looked thru the forums extensively and have tried just about every suggestion and workaround that has been offered. the iw-mount is running on port 81, ive opened the web service extension so that ASP and SSI are allowed, ive tried changing the anonymous access user from IUSR_[server] to TSIMP_[server], yadder, yadder, yadder.
the error that appears when you try to preview/generate a particular file either by clcking on it directly or thru a DCR is:
Active Server Pages error 'ASP 0126'
Include file not found
/iw-mount/Rci/main/theburbs/Burbs_training/WORKAREA/content/burbs_training/default.asp, line 6
The include file '/Burbs_training/include/top.inc' was not found.
this file does exist, as ive traced back to it.
ive also looked thru the log files and the errors that stick out are in the iw-webd\logs\error.log:
[Fri Nov 26 09:39:13 2004] [error] [client 10.10.30.110] Use of uninitialized value in concatenation (.) or string at (eval 28) line 316
and the iwtrace.log (lots of these):
[Thu Nov 25 18:33:13 2004] TBkgJobsDriver::ThawAllJobs jobsSet 0x127; AsBkgJobsSet() failed
any help would be greatly appreciated as im pretty sure that this is the one stumbling block that is holding me back from a successful installation. if you need any more info on this, please let me know.
regards,
brendan gleeson
Find more posts tagged with
Comments
Johnny
I'm no real help when it comes to ASP but,
/iw-mount/Rci/main/theburbs/
B
urbs_training/WORKAREA/content/
b
urbs_training/default.asp, line 6
The include file '/
B
urbs_training/include/top.inc' was not found.
I noticed a capital b Burbs_training/include/top.inc, but the workarea contains a directory with a lower case b.
I dont know if IIS is case sensitive in this situation
John Cuiuli
bpg
thanks for the suggestion john, but im pretty sure that IIS is not dependent on case-sensitivity. you can susually web to any directory under the root without being specific about case. but if anyone could eliminate this possibilty, that would be great.
regards,
brendan
Johnny
try creating another workarea that matches the case.
That way you can eliminate the possibility yourself.
John Cuiuli
bpg
when you try and create another folder with a capital instead of a lower case, then it says that a fodler with that name already exists. this kinda tells me that case-sensitivty is not an issue. thanks for your comments anyway.
any other suggestions?
regards,
brendan
anthonyl
OK, I assume you mean ALL .asp files can't be previewed. The only things I can think of that you didn't mention (you may have done them anyway) was to make sure that the iwproxy_isapi.dll is in place and working, that you have the correct proxy remaps in iw.cfg. If you have done that, try stopping the iwproxy service and then running iwproxy -d from the command line, that should give you better ability to trace what is being called and whether your remaps etc are working.
Cheers,
Ant.
bpg
many thanks anthony, this seemed to be the problem. somehow i managed to miss off the isapi filter install during the teamsite installation.
i dont feel stupid at all. really....
may thanks for everyone's help.
brendan