Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
OpenDeploy transactional=yes crashes OD receivers
NathansDIS
Hello-
We have a transactional deployment targeting 2 IIS web servers. The destination directory is also the root of a .NET web application. The recievers crash when they are unable to rename the folder that is the root of the IIS web/.NET application. Does anyone have any insight into how to configure or correct this issue? I have worked with support to increase the svrTryCount and svrTryInterval which has not solved the issue. The tail of the rcvr log is shown below. Support says errorno=5 is a message from the OS indicating 'access denied.' We are on Win2k, TS 6.1, OD 6.0. Any insight, suggestions, past experiences much appreciated.
Regards,
Nathan
Washington DIS
~~~
ENG: 2004-11-04 10:48:44 PST GMT-08:00 Thread-677 exiting awaiting-commit
ENG: 2004-11-04 10:48:44 PST GMT-08:00 Thread-677 entering commit
LIB: id=0 2004-11-04 10:48:44 FailedCommit 0.
LIB: id=0 2004-11-04 10:48:44 COMMITTING Transactional Deployment
LIB: (3) id=0 2004-11-04 10:48:44 Renaming: [E:\awroot\awui\web.iwnew] -> [E:\awroot\awui\web]
LIB: (3) id=0 2004-11-04 10:48:44 Cleaning: E:\awroot\awui\web
LIB: (3) id=0 2004-11-04 10:48:44 Deleting dir: E:\awroot\awui\web
LIB: (3) id=0 2004-11-04 10:48:59 Deleted: E:\awroot\awui\web
LIB: (3) id=0 2004-11-04 10:49:00 Copying dir: E:\awroot\awui\web.iwnew to E:\awroot\awui\web
LIB: 2004-11-04 10:49:00 ERROR: Failed to create directory (E:\awroot\awui\web\aboutWa), errno=5
LIB: 2004-11-04 10:49:00 ERROR: Failed to create directory (E:\awroot\awui\web\agency), errno=5
LIB: 2004-11-04 10:49:00 ERROR: Failed to create directory (E:\awroot\awui\web\bin), errno=5
LIB: 2004-11-04 10:49:00 ERROR: Failed to create directory (E:\awroot\awui\web\business), errno=5
LIB: 2004-11-04 10:49:00 ERROR: CopyFile Failed while copying from (E:\awroot\awui\web.iwnew\CauseError.aspx) to (E:\awroot\awui\web\CauseError.aspx), errno=5
LIB: 2004-11-04 10:49:00 ERROR: Failed copying dir(E:\awroot\awui\web.iwnew) to (E:\awroot\awui\web)
Find more posts tagged with
Comments
Migrateduser
maybe inadequate permissions on the folder/directory?
Adam Stoller
You might be able to configure OD to use a specific directory for temporary files - which might help eliminate the need to rename the directory.
I don't recall what the option is off-hand but it should be documented.
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com
NathansDIS
Hmm. SYSTEM has full control to the directory. Also, OD has no problem creating or renaming other folders in the structure, it just seems like IIS/.NET(via the OS) has a kung-fu grip on the root of the web/app.
Adam Stoller
I understand that - .NET or IIS almost definitely has a process holding onto that directory or a file within it - and you won't be able to do anything about unless you (A) shut down / restart those services as part of DNR scripts that run before / after the deployment or (B) *possibly* change the locaton of the temporary files such that it may not try to rename that directory at all -- I'm not sure about it, haven't tried this feature out in any environment yet and I'm not working in a Windows environment at all right now (thankfully) - so you're mileage may vary.
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com
NathansDIS
Thx, I'm researching now and will update the case with my findings.
-n
Migrateduser
yeah try to logon the box and manually create a file or rename the folder in the problem directory just to verify what fish said.
NathansDIS
I can create and rename files in the root directory all day, just can't rename the root itself...