Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
OpenDeploy and DFS
foxman
Hi,
I was just wondering if anyone had any experience using OpenDeploy with Microsoft DFS. We are running OD 5.6 on TeamSIte 6.01 to 2 x Windows 2000 servers which have been configured to use DFS file replication.
I was planning to just deploy to both servers as a transactional fanout and while the deployment worked fine, the DFS recognised a change on each server and tried to replicate it, got confused and left a couple of temporary DFS directories (staging areas?!) on the targets.
I dont want to deploy to a single server because if it is down for any reason, all our deployments will start to fail.
Is there a way to deploy directly to the DFS? If not, can anyone suggest best practice here? I realise you could probably deploy to one, test for succecss and then move on or not and follow that to the end, but what a convoluted way to get files out to 2 boxes that would simply need a transactional fan out!
Any help appreciated
Andrew
Find more posts tagged with
Comments
Adam Stoller
If I'm understanding the situation correctly, I think the problem is that the target area on the two receivers is actually the *same* area - if so, you are running into problems because you are trying to deploy the same content *twice* to the same area at the same time.
You could either deploy to different areas on the receivers (defeats the DFS purpose) or you could do a serialized deployment where you deploy to one node, then deploy to the other node (passing the name of the node in on the command line with a '-k' parameter).
You'll end up with some redundancy, but it should do, effectively, what you want. If you check the success/failure of the previous run to determine if you need to do a subsequent run - you may save some deployment time, but you can probably run them sequentially regardless of interim checks (the only issue here is that if the first run succeeded and the second failed because the second target machine was down - you may get a false negative)
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com
Migrateduser
Also keep in mind that OD will create temporary copies of files on the target during the deployment. So if your system reacts to changes in directory contents, you may want to consider using OD 6.0, which lets you configure the receiver to write temp files to an alternate directory (i.e., not the actual target directory.)
Todd Scallan
Director of Product Management
Interwoven
t: 408-530-7167
e:
tscallan@interwoven.com