Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
TS 6.5 Event Subsystem
Mfitch
Trying to configure TS 6.5
seeing the following error:
org.exolab.jms.server.ServerException: org.exolab.jms.persistence.PersistenceException: org.apache.commons.dbcp.SQLNestedException:
Cannot create PoolableConnectionFactory, cause:
java.sql.SQLException: Io exception: The Network Adapter could not establish the connection
at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:180)
at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:222)
at oracle.jdbc.dbaccess.DBError.throwSqlException(DBError.java:335)
at oracle.jdbc.driver.OracleConnection.<init>(OracleConnection.java:361)
at oracle.jdbc.driver.OracleDriver.getConnectionInstance(OracleDriver.java:442)
at oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:321)
at org.apache.commons.dbcp.DriverConnectionFactory.createConnection(DriverConnectionFactory.java:82)
at org.apache.commons.dbcp.PoolableConnectionFactory.makeObject(PoolableConnectionFactory.java:300)
at org.apache.commons.dbcp.BasicDataSource.validateConnectionFactory(BasicDataSource.java:838)
at org.apache.commons.dbcp.BasicDataSource.createDataSource(BasicDataSource.java:821)
at org.apache.commons.dbcp.BasicDataSource.getConnection(BasicDataSource.java:518)
at org.exolab.jms.persistence.DBCPConnectionManager.getConnection(Unknown Source)
at org.exolab.jms.persistence.RDBMSAdapter.getConnection(Unknown Source)
at org.exolab.jms.persistence.RDBMSAdapter.<init>(Unknown Source)
at org.exolab.jms.persistence.DatabaseService.createRdbmsAdapter(Unknown Source)
at org.exolab.jms.persistence.DatabaseService.<init>(Unknown Source)
at org.exolab.jms.persistence.DatabaseService.instance(Unknown Source)
at org.exolab.jms.server.JmsServer.registerServices(Unknown Source)
at org.exolab.jms.server.JmsServer.init(Unknown Source)
at org.exolab.jms.server.JmsServer.main(Unknown Source)
this "feels like" the jdbc driver is not being found - it is installed under ORACLE_HOME
do I need to set / modify some environmental variable?
Find more posts tagged with
Comments
Migrateduser
No, the oracle jdbc drivers are shipped with Teamsite. This looks more like a case of bad configuration or the listener process is not running on the database service. Can you check the configuration in IWHOME/eventsubsystem/conf/jmsconfignew.xml and also make sure the listener service is running on the database server.
Mfitch
you were right -(sort of)
the tnsnames.ora had a slightly different reference
(to the cluster vs. individual node) to the db server
than what was in the config file -
changing the config file to match tnsnames moves the process forward.