Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
Open Deploy - Scheduler Errors
John742
Solaris- Teamsite 5.5.2 OD 5.5.1
I am getting an error when Open Deploy tries to Initalize the Scheduler :
***ERROR - SQLException: Wrong database file version
I have to blow out the scheduler files and restart Open Deploy to fix. Anyone have any ideas? It has happened twice in the last week, but beofre that all was well.
Here is the complete log:
ENG: 2004-12-07 02:22:18 EST GMT-05:00 Initializing scheduler
ENG: 2004-12-07 02:22:18 EST GMT-05:00 ***ERROR - SQLException: Wrong database file version
java.sql.SQLException: Wrong database file version
at org.hsql.Trace.getError(Trace.java:124)
at org.hsql.Trace.getError(Trace.java:115)
at org.hsql.Trace.check(Trace.java:149)
at org.hsql.Trace.check(Trace.java:145)
at org.hsql.Log.open(Log.java:99)
at org.hsql.Database.<init>(Database.java:44)
at org.hsql.jdbcConnection.openStandalone(jdbcConnection.java:655)
at org.hsql.jdbcConnection.<init>(jdbcConnection.java:524)
at org.hsql.jdbcDriver.connect(jdbcDriver.java:78)
at java.sql.DriverManager.getConnection(DriverManager.java:517)
at java.sql.DriverManager.getConnection(DriverManager.java:177)
at com.interwoven.deploy.engine.TMacroDeployInitiator.compactHsql(TMacroDeployInitiator.java:1694)
at com.interwoven.deploy.engine.TMacroDeployInitiator.initScheduler(TMacroDeployInitiator.java:123)
at com.interwoven.deploy.engine.TMacroDeployInitiator.<init>(TMacroDeployInitiator.java:85)
at com.interwoven.deploy.engine.TDeploySvrEngine.<init>(TDeploySvrEngine.java:357)
at com.interwoven.deploy.engine.TDeploySvrEngine.create(TDeploySvrEngine.java:130)
at com.interwoven.deployapi.service.IWODServiceServer.main(IWODServiceServer.java:957)
ENG: 2004-12-07 02:22:18 EST GMT-05:00 ***ERROR - Compacting HSQL script file
ENG: 2004-12-07 02:22:18 EST GMT-05:00 ***ERROR - SQLException: Wrong database file version
java.sql.SQLException: Wrong database file version
at org.hsql.Trace.getError(Trace.java:124)
at org.hsql.Trace.getError(Trace.java:115)
at org.hsql.Trace.check(Trace.java:149)
at org.hsql.Trace.check(Trace.java:145)
at org.hsql.Log.open(Log.java:99)
at org.hsql.Database.<init>(Database.java:44)
at org.hsql.jdbcConnection.openStandalone(jdbcConnection.java:655)
at org.hsql.jdbcConnection.<init>(jdbcConnection.java:524)
at org.hsql.jdbcDriver.connect(jdbcDriver.java:78)
at java.sql.DriverManager.getConnection(DriverManager.java:517)
at java.sql.DriverManager.getConnection(DriverManager.java:177)
at com.interwoven.deploy.engine.TMacroDeployInitiator.initScheduler(TMacroDeployInitiator.java:157)
at com.interwoven.deploy.engine.TMacroDeployInitiator.<init>(TMacroDeployInitiator.java:85)
at com.interwoven.deploy.engine.TDeploySvrEngine.<init>(TDeploySvrEngine.java:357)
at com.interwoven.deploy.engine.TDeploySvrEngine.create(TDeploySvrEngine.java:130)
at com.interwoven.deployapi.service.IWODServiceServer.main(IWODServiceServer.java:957)
ENG: 2004-12-07 02:22:18 EST GMT-05:00 *** OpenDeploy Server is a receiver ***
ENG: 2004-12-07 02:22:18 EST GMT-05:00 *** Fan-out capability enabled ***
SVR: 2004-12-07 02:22:18 EST GMT-05:00 Starting OpenDeploy engine component.
ENG: 2004-12-07 02:22:19 EST GMT-05:00 Getting the local Node = neptune.dominionnet.com
ENG: 2004-12-07 02:22:19 EST GMT-05:00 Creating session listener on port 20014...
ENG: 2004-12-07 02:22:19 EST GMT-05:00 Receiver-side handshake timeout = 120 secs
ENG: 2004-12-07 02:22:19 EST GMT-05:00 Session Listener bound on [neptune.dominionnet.com:20014]...
ENG: 2004-12-07 02:22:19 EST GMT-05:00 Starting scheduler
ENG: 2004-12-07 02:22:19 EST GMT-05:00 Catching up all scheduled deployments
ENG: 2004-12-07 02:22:19 EST GMT-05:00 ***ERROR - SchedulerException: getting jobs: You must call setSqlAccess() immediately after creating the scheduler. The method setSqlAccess() has not been called successfully.
org.publicinterface.js.SchedulerException: You must call setSqlAccess() immediately after creating the scheduler. The method setSqlAccess() has not been called successfully.
at com.simscomputing.js.SchedulerImpl.verifySetSqlAccess(SchedulerImpl.java)
at com.simscomputing.js.SchedulerImpl.size(SchedulerImpl.java)
at com.interwoven.deploy.engine.TMacroDeployInitiator.catchUpAllJobs(TMacroDeployInitiator.java:1769)
at com.interwoven.deploy.engine.TMacroDeployInitiator.startScheduler(TMacroDeployInitiator.java:1841)
at com.interwoven.deploy.engine.TMacroDeployInitiator.start(TMacroDeployInitiator.java:255)
at com.interwoven.deploy.engine.TDeploySvrEngine.start(TDeploySvrEngine.java:784)
at com.interwoven.deployapi.service.IWODServiceServer.main(IWODServiceServer.java:962)
ENG: 2004-12-07 02:22:19 EST GMT-05:00 - starting scheduler: AGENT_INITIATOR_FAILED
message: AGENT_INITIATOR_FAILED
Details: SchedulerException: getting jobs: You must call setSqlAccess() immediately after creating the scheduler. The method setSqlAccess() has not been called successfully.
org.publicinterface.js.SchedulerException: You must call setSqlAccess() immediately after creating the scheduler. The method setSqlAccess() has not been called successfully.
at com.simscomputing.js.SchedulerImpl.verifySetSqlAccess(SchedulerImpl.java)
at com.simscomputing.js.SchedulerImpl.size(SchedulerImpl.java)
at com.interwoven.deploy.engine.TMacroDeployInitiator.catchUpAllJobs(TMacroDeployInitiator.java:1769)
at com.interwoven.deploy.engine.TMacroDeployInitiator.startScheduler(TMacroDeployInitiator.java:1841)
at com.interwoven.deploy.engine.TMacroDeployInitiator.start(TMacroDeployInitiator.java:255)
at com.interwoven.deploy.engine.TDeploySvrEngine.start(TDeploySvrEngine.java:784)
at com.interwoven.deployapi.service.IWODServiceServer.main(IWODServiceServer.java:962)
at com.interwoven.deploy.engine.TMacroDeployInitiator.catchUpAllJobs(TMacroDeployInitiator.java:1808)
at com.interwoven.deploy.engine.TMacroDeployInitiator.startScheduler(TMacroDeployInitiator.java:1841)
at com.interwoven.deploy.engine.TMacroDeployInitiator.start(TMacroDeployInitiator.java:255)
at com.interwoven.deploy.engine.TDeploySvrEngine.start(TDeploySvrEngine.java:784)
at com.interwoven.deployapi.service.IWODServiceServer.main(IWODServiceServer.java:962)
Find more posts tagged with
Comments
John742
I may have found the problem:
I have schedules that run every 10 minutes
I have a backup job that freezes the backing store in teamsite and stops all processes at midnight. It appears that since my deployments run on the hour, killing opendeploy while it is reading/writing to the scheduler files is corrupting them.
I have changed my schedule to run 5 minutes off and we will see if this fixes the issue.
If anyone has any other Ideas let me know!! Thanks!!
John742
Unfortunately I am still having the problem. I am still leaning toward the scheduler files getting corrupted, but I have no idea on have to verify this. Does anyone have any suggestions? The group responsible for running our backup says that everything is being shut down correctly; does anyone know what might be corrupting the scheduler files? Any assistance is appreciated!!
Migrateduser
You might want to check the OD base server log to see if it indeed is being shut down completely prior to the backup.
How many schedule entries to you have?
Todd Scallan
Director of Product Management
Interwoven
t: 408-530-7167
e:
tscallan@interwoven.com
John742
The od base log does not show anything being shutdown, just the start up of OD. What would be listed in the log to indicate a proper shutdown? We currently have 2 scheduled deployments one at 10 minutes the other 15. Thanks for the help.
Migrateduser
The OD server log should contain something like this (extracted from my OD 6.0.1 base server log)...
WEB 01009: 2004-12-20 09:04:09 PST GMT-08:00 Begin OpenDeploy web server shutdown.
WEB 01010: 2004-12-20 09:04:09 PST GMT-08:00 *** Finished OpenDeploy Web server shutdown ***
SEC: 2004-12-20 09:04:09 PST GMT-08:00 Begin server security shutdown.
SEC: 2004-12-20 09:04:09 PST GMT-08:00 No need to update Opendeploy Admin role DB File.
SEC: 2004-12-20 09:04:09 PST GMT-08:00 No need to update OpenDeploy User role DB File.
SEC: 2004-12-20 09:04:09 PST GMT-08:00 Finished server security shutdown.
ENG: 2004-12-20 09:04:09 PST GMT-08:00 Stopping OD server engine ...
ENG: 2004-12-20 09:04:09 PST GMT-08:00 Stopping listener on 20014
ENG: 2004-12-20 09:04:09 PST GMT-08:00 Stopped listener on port 20014
ENG: 2004-12-20 09:04:09 PST GMT-08:00 Receiver stopped.
ENG: 2004-12-20 09:04:09 PST GMT-08:00 Shutting down scheduler
ENG: 2004-12-20 09:04:09 PST GMT-08:00 Opened HSQL jdbc connection
ENG: 2004-12-20 09:04:09 PST GMT-08:00 Executed SHUTDOWN COMPACT
ENG: 2004-12-20 09:04:09 PST GMT-08:00 Closed HSQL jdbc connection
ENG: 2004-12-20 09:04:09 PST GMT-08:00 Compacted HSQL script file
ENG: 2004-12-20 09:04:09 PST GMT-08:00 Successfully updated schedule extension file
ENG: 2004-12-20 09:04:09 PST GMT-08:00 Sender stopped.
ENG: 2004-12-20 09:04:09 PST GMT-08:00 Listener stopped.
ENG: 2004-12-20 09:04:09 PST GMT-08:00 Stopping event server ...
ENG: 2004-12-20 09:04:17 PST GMT-08:00 Event server stopped.
ENG: 2004-12-20 09:04:17 PST GMT-08:00 OD server stopped.
Todd Scallan
Director of Product Management
Interwoven
t: 408-530-7167
e:
tscallan@interwoven.com
John742
Great!! Thanks for the log info. I believe that OD is not being shutdown properly. I will compare it to mine, but I am sure it does not look like this.