Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
iwmtbatch
Sunil Mugalavally
Hi,
Teamsite 5.5.2 SP 3
Metatagger 3.5.1
on separate NT box
I am trying to run iwmtbatch form a presentation template and I get a "Access is denied" error logged in the error.log file.
Here is the command i call from the PT.
`iwmtbatch -suggest -save -verbose $dcrname`
Is this access denied to the "iwmtbatch" executable or is it something else ?
Do I need to give perms to the TS user who generates the page?
Any help is appreciated.
Thanks
Find more posts tagged with
Comments
Migrateduser
Hi sunny. What is the platform of the TS host? The problem may be environment variables or user permissions.
Initial debugging/troubleshooting remarks:
You're probably calling iwmtbatch within perl script?
What are the env var settings as seen within the script? e.g. PATH=?, LD_LIBRARY_PATH=? (if sol)
Who is OS user as seen within the script?
Is the intended executable being executed at all? e.g. is iwmtbatch in the PATH?
Does the mtserver_9095.log on MT host show movement? (i.e. is clt being run and contacting the mtserver?)
My guess is that the "Access is denied" message is probably happening before execution of iwmtbatch is kicked off
(or just as it is being kicked off, as in failure to execute iwmtbatch within perl script, so iwmtbatch is never really reached).
Sunil Mugalavally
Hi Jones,
We are on Windows 2000. Teamsite and Metatagger are on different servers.
Yes. I am calling the "iwmtbatch" cmd from with in a presentation template on the teamsite server.
The PATH Env Var is set to
%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;c:\winnt\webteamadmin;C:\Program Files\Microsoft SQL Server\80\Tools\BINN;C:\Program Files\Support Tools\;C:\Program Files\Interwoven\MetaTagger\bin;C:\Program Files\Interwoven\MetaTagger\thirdparty;C:\Program Files\Interwoven\MetaTagger\thirdparty\charsets
The OS user as seen with in the script is the user who generates the page from DCR.
There is no noticable movement on the mtserver_9095.log on the MT server. Even I suspect that its failing even before it can execute the iwmtbatch cmd from teamsite perl script.
Although the same command runs on command line on MT box.
-Sunil
Adam Stoller
The PATH Env Var is set to
%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;c:\winnt\webteamadmin;C:\Program Files\Microsoft SQL Server\80\Tools\BINN;C:\Program Files\Support Tools\;C:\Program Files\Interwoven\MetaTagger\bin;C:\Program Files\Interwoven\MetaTagger\thirdparty;C:\Program Files\Interwoven\MetaTagger\thirdparty\charsets
Did you get that information from the shell, the Environment viewer or from outputting the information within the script that you are using to invoke iwmtbatch?
Unless it was the latter - it doesn't mean as much - you need to make sure that the environment
within
the script is the same (or at least that amount which matters) as it is outside the script.
If you're using Perl - you can do something simple like this:
if (open(OUT, ">c:/temp/script.log")){
print OUT "$_ => $ENV{$_}\n" foreach(sort(keys(%ENV)));
close(OUT);
}
Hope that helps ...
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com
Sunil Mugalavally
I got this info from the Environment viewer on the MT Server.
Here is what i get from running ur code in the perl script.
PATH => C:\WINNT\system32;C:\WINNT;C:\WINNT\System32\Wbem;C:\Program Files\Resource Kit;C:\Program Files\Support Tools;C:\Program Files\UMS;C:\PROGRA~1\UMS\Director\bin;C:\WINNT\WebTeamAdmin;C:\Program Files\Microsoft SQL Server\80\Tools\BINN;C:\Program Files\Common Files\Interwoven\lib;C:\iw-home\tools\db\sybase\sqlanywhere-7.0.1\win32\lib;c:\iw-home\bin;c:\iw-home\iw-perl\bin;;C:\MetaTagger\bin;C:\MetaTagger\thirdparty;C:\MetaTagger\thirdparty\charsets
Here I see. The PATH var is set differently in the two places.
I will have the PATH var changed to the one from the MT ENV Viewer (which is correct) in Teamsite Box and test it.
Thanks very much Ghoti.
Migrateduser
Maybe try inserting a BEGIN block where you set those variables within the tpl itself.
Sunil Mugalavally
Hi,
This was a NT permission issue on the "C:/Metatagger/bin" dir.
I just set Read, write and Execute perms on this dir for the Teamsite user group.
Everything works fine now.
Thanks very much for all the help.
-Sunil