Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Web CMS (TeamSite)
opendeploy error
diago
we use opendeploy 5.5.1 on unix
we have the following error in log
ENG: 2004-09-16 08:17:42 GMT+00:00 GMT+00:00 ***ERROR - SQLException: The database is already in use by another process
java.sql.SQLException: The database is already in use by another process
at org.hsql.Trace.getError(Trace.java:124)
at org.hsql.Trace.getError(Trace.java:115)
at org.hsql.Trace.error(Trace.java:127)
at org.hsql.Log.open(Log.java:115)
at org.hsql.Database.<init>(Database.java:44)
at org.hsql.jdbcConnection.openStandalone(jdbcConnection.java:655)
at org.hsql.jdbcConnection.<init>(jdbcConnection.java:524)
at org.hsql.jdbcDriver.connect(jdbcDriver.java:78)
at java.sql.DriverManager.getConnection(DriverManager.java:517)
at java.sql.DriverManager.getConnection(DriverManager.java:177)
at com.interwoven.deploy.engine.TMacroDeployInitiator.initScheduler(TMacroDeployInitiator.java:143)
at com.interwoven.deploy.engine.TMacroDeployInitiator.<init>(TMacroDeployInitiator.java:79)
at com.interwoven.deploy.engine.TDeploySvrEngine.<init>(TDeploySvrEngine.java:352)
at com.interwoven.deploy.engine.TDeploySvrEngine.create(TDeploySvrEngine.java:125)
at com.interwoven.deployapi.deploy.IWDeployServiceRemoterImpl.<init>(IWDeployServiceRemoterImpl.java:915)
at java.lang.reflect.Constructor.newInstance(Native Method)
at com.interwoven.deployapi.service.IWODServiceServer.startService(IWODServiceServer.java:373)
at com.interwoven.deployapi.service.IWODServiceServer.startServiceList(IWODServiceServer.java:296)
at com.interwoven.deployapi.service.IWODServiceServer.server(IWODServiceServer.java:158)
at com.interwoven.deployapi.service.IWODServiceServer.main(IWODServiceServer.java:169)
any hints ?
regards
Eric Grandjean
Find more posts tagged with
Comments
Adam Stoller
I'm guessing this is either the scheduler db and that perhaps something wasn't shut down properly before someone tried to [re]start OpenDeploy such that there may already be a process accessing the db.
Try shutting down OpenDeploy (/etc/init.d/iwod stop) - waiting a few minutes - and then re-starting it (/etc/init.d/iwod start) and see if everything works again. If not, perhaps contact Support (or post more details here?)
--fish
Senior Consultant, Quotient Inc.
http://www.quotient-inc.com