Home Analytics Developing analytics applications
The community of Analytics developers are invited to follow and participate in the developer network.
OpenText technical experts collaborate with supported customers and partners in the Magellan product area.

Persian characters in pdf view

alirezaSalirezaS Junior Member
edited December 31, 1969 in Developing analytics applications
Hi,all.
I'm using birt 2.3.2 and I have a very confusing problem with it.I've build a report contains some persian strings.When I try to preview it in pdf from all-in-one there is no problem and everything is so nice,BUT when I try to deploy the report in my j2ee application and run report with a pdf result,some characters are incorrect.
Does anyone know how I can solve this problem or at least how I can search for the root cause of this problem????

Tnx all

Comments

  • edited December 31, 1969
    I assume the tomcat installation is on a separate machine?
    If so can you install tomcat locally to test?

    Jason
  • alirezaSalirezaS Junior Member
    edited December 31, 1969
    tnx for your reply,first of all.
    I run the report in JBoss.
    I've focused more.I've found that in design time and also view in web there is the same problem.The generated pdf file don't show special persian characters which are not same as arabic character.
    (There are some common character in arabi and farsi(persian) which has different shapes in two languages and also farsi has 4 more characters than arabic.It seems that birt consider them as arabic)

    tnx again for your attention
  • edited December 31, 1969
    Can you log a bug for this?

    Jason
  • alirezaSalirezaS Junior Member
    edited December 31, 1969
    I'll do.tnx for your attention.

    Alireza
  • maheydarimaheydari Junior Member
    edited December 31, 1969
    Would you please tell me how you resolve your problem?I also have this problem with some persian character.
    When I see the report in PDF format some character(گ، پ ،چ ) showed separated and these character can't attach to the word such as (پ یش).

    Thanks in advance
  • edited December 31, 1969
    Take a look at this bug entry



    https://bugs.eclipse.org/bugs/show_bug.cgi?id=155551



    I believe there is a link to a work around.



    Jason
  • maheydarimaheydari Junior Member
    edited December 31, 1969
    I really appreciate for your answer.
  • Hello All,

      This issue is still faced with the newest birt edition 3.7.x and 4.x.x . The link provided in the turnaround is invalid. Is there any chances that we find a fix for this case?

    Regards

    Regards
    Elia
  • grathergrather Junior Member

    I had similar issue but with Chinese.

     

    Open up the PDF and check the font that is being used.

    If that font does not have all the characters.

     

    You need to figure out what font will work for you.

     

    I found for my Chinese the font to deal with Chinese was SimSum.ttf

     

    Then I modified the font for pdf in locale = chinese to use SimSum.ttf

     

    Then I had to make sure my production server had the proper font available.

     

    Gary

Sign In or Register to comment.