Can't run API/DQL, dm_agent_exec auth failed

jeremyprioux
edited December 2, 2009 in Documentum #1

Hi,

I've two Docbases with the same error (on the same content server), when trying to lauch API32 or DQL32 (or run dmbasic script) :

Couldn't connect  as ADMIN_NAME

[DM_SESSION_E_CLIENT_AUTHENTICATION_FAILURE]error:   "Failed to authenticate client.  Please check server log for more  detail."

Even when i'm starting my Content Server, i've not friendly logs :

Thu Nov 05  18:30:41 2009 [FATAL ERROR] [AGENTEXEC 4888] Detected during program  initialization: Command Failed:  connect,DOBCASE.DOCBASE,ADMIN_NAME,'',,,try_native_first, status: 0,  with error message .

The  dm_agent_exec utility is exiting due to a fatal  error.

Thu Nov 05  18:31:41 2009 000000 [DM_SESSION_W_AGENT_EXEC_FAILURE_EXCEED]warning:  "The  failure limit of the agent exec program has exceeded. It will not be restarted  again. Please correct the problem and restart the  server."

I think everything was OK before I installed my full-text indexer (not on the same server that my Content Server), but I'm not sure it's really related...

I've installed one more Docbase (with no agent indexer) and everything is right with this one !

any hints? Keep in mind that i'm new in documentum world, so it might be newbie issue related

Thank you

PS : documentum 6.5 sp2

Tagged:

Best Answer

  • lastnitescurry
    edited November 18, 2009 #2 Accepted Answer

    Stop all services.

    flush cache and logs (as you already did)

    Move *.keystore (dfc.keystore and wdk.keystore on mine) out of the config folder(s) which has dfc.properties.

    The keystore file is (re)generated automiatically.... it is tied to server IP... if the IP changes then it will cause login failures.

    And reboot again just to be paranoid android

Answers

  • clonak
    clonak Kelly Clonan
    edited November 17, 2009 #3

    Hi there Jeremy:

    I have moved your question over to an amazingly technical community that may be able to assist you with your API/DQL run issue.

    We are glad you are using the communities for your daily needs.  Keep on participating!

    Many thanks,
    Kelly

  • BTMSoftware
    edited November 18, 2009 #4

    any changes in your config ? like domain name, admin passwords etc...

    Did you try a good old reboot of your server ? I know server should run 24/7 but rebooting them from time to time can't hurt them either

  • jeremyprioux
    edited November 18, 2009 #5

    I can't remember any changes I've done, apart from installing the fulltext indexer (on another machine).

    This server is for development purpose so I've reboot and it's still the same.

    I would like to use some API command to flush the cache etc... but that especially what I can't do : using api, dql etc..! Also I would like to add some locales using dmbasic script, and I can't do it

  • lastnitescurry
    edited November 18, 2009 #6 Accepted Answer

    Stop all services.

    flush cache and logs (as you already did)

    Move *.keystore (dfc.keystore and wdk.keystore on mine) out of the config folder(s) which has dfc.properties.

    The keystore file is (re)generated automiatically.... it is tied to server IP... if the IP changes then it will cause login failures.

    And reboot again just to be paranoid android

  • jeremyprioux
    edited November 18, 2009 #7

    Brian you're my hero !

    Deleting the dfc.keystore and reboot solved my problem. I never changed my server IP so I don't know exactly what was the original source of the problem... (index agents from fulltext server maybe).

  • BTMSoftware
    edited November 18, 2009 #8

    I suppose your server is assigned an IP address automatically. I remember reading somewhere (can;t remember where though, maybe in some Documentum doc) that it's a good practice for the Documentum server to have a fixed IP address

    My 2 cents

  • jeremyprioux
    edited November 18, 2009 #9
    IP is fixed here (due to network config, not a "good practice" idea). But thanks for the advice !
  • BTMSoftware
    edited November 18, 2009 #10
    Actually meant good practice in the Documentum world, not necessarily in the real world
  • clonak
    clonak Kelly Clonan
    edited November 18, 2009 #11

    Hey there Jeremy:

    I'm glad I steered you in the right direction.  These Developer Community experts are amazing!  The smartest technical contact base is right here in the Community.

    Glad you got some resolution.

    Best regards,

    Kelly

  • lastnitescurry
    edited November 19, 2009 #12

    glad to be of help... keystore appeared with the change over to java dmcl (5.3sp5).... tripped me up a few times... espically since I have moved to the virtual world (vmware).

    I now include keystore kill in my cache & logs clean script.

  • jeremyprioux
    edited November 19, 2009 #13

    Did I omit to say that I'm working with a virtual machine ? (vmware)

    Sorry about that, I didn't know it was usefull !

  • 12345qwert
    12345qwert sailor_man ks
    edited December 2, 2009 #14

    Hi,

    i've the same problem as was mentioned in main post, but i'm use 5.3sp6 (AIX, Oracle 9.2.0.8 Documentum 5.3sp6).

    There aren't (on filesystem) file dfc.keystore etc.

    Does anyone know how resolve it in my case.

    with kindest regards,

    Krzyszof

  • Panvivek
    edited February 20, 2019 #15

    will post ques in other

  • Hi Panvivek - its bad forum etiquette to piggyback off of someone else thread. Please start a new thread.