dqman runs but keeps crashing

Hello Guys, I have been able to successfully run dqman version 6 with repository version 16.4
I have done this using DFC 6.7SP2, 7.1, 7.2 and 16.4 individually.
I have used KB article below as well. 

KB10030004


However I am facing the issue that dqman keeps crashing. I have tried on Windows 7 and Windows 10 as well with the same results.
I get the below error in Event Viewer.
Any help is greatly appreciated.

Faulting application name: dqman.exe, version: 6.0.1.34, time stamp: 0x5ccac346
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x09d6a1b1
Faulting process id: 0x214
Faulting application start time: 0x01d64a434624febc
Faulting application path: C:\Dev\dqMan\dqman.exe
Faulting module path: unknown
Report Id: a48a856c-b636-11ea-b7c2-0050568f2fa2
«1

Comments

  • Unfortunately, since dqman is not written/owned by OpenText, they are not supporting this.  Its up to FME to fix this.
  • Thanks Johnny. Have you seen or faced this issue yourself or someone that you know of?
    Any recommendations in terms of other tools available? I do not want to compile source code to get the tool - just want a standard executable.

  • Unfortunately, we had to stop using dqman after our 16.4 upgrade.  IDQL is the only way we can run large queries that will cause DA to timeout.
  • s_vaidyas_vaidya Samir Vaidya EM
    I have not tried, but there is another similar product named DQL Buddy. They had a booth during previous year Enterprise World at Toronto, and product seemed to provide similar functionality:

    https://www.informedgroup.com/dqlbuddy/

    Samir Vaidya
    Enterprise Software Architect
    OpenText

  • Thanks Samir. I have been able to get DQL Buddy working. However when I try to Execute a DQL, I get the below error.
    Have you encountered this as well?

    null
    java.lang.NullPointerException

    at com.informedgroup.dqlbuddy.model.utils.ConfigDBUtils.getCategoryItemsList(ConfigDBUtils.java:1051)

    at com.informedgroup.dqlbuddy.model.utils.ConfigDBUtils.getCategoryItemsFromAllDB(ConfigDBUtils.java:1277)

    at com.informedgroup.dqlbuddy.gui.DqlQueryLibraryTab.initGUI(DqlQueryLibraryTab.java:224)

    at com.informedgroup.dqlbuddy.gui.DqlQueryLibraryTab.<init>(DqlQueryLibraryTab.java:175)

    at com.informedgroup.dqlbuddy.gui.DQLBuddyApp$8.widgetSelected(DQLBuddyApp.java:703)

    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:252)

    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:89)

    at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4173)

    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1057)

    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3986)

    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3585)

    at com.informedgroup.dqlbuddy.gui.DQLBuddyApp.main(DQLBuddyApp.java:141)

  • s_vaidyas_vaidya Samir Vaidya EM
    As I said, I have not tried this product myself. You can try dropping mail to contact details on informedgroup.com. I did see it working though at their booth last year.

    Another tool I saw was on Github - again, I have not tried this too:

    https://github.com/HetBenkt/DQL-Tester-FX

    Samir Vaidya
    Enterprise Software Architect
    OpenText

  • PedroMaiaPedroMaia Senior Consultant (OpenText) EM
    I can confirm that I have dqMan working with Documentum 16.7.
    Regarding DQL Buddy, I get the same error as you, so I guess we have to go to Informed for support.
    Regarding DQL-Tester-FX it works, but is a bit slow and not as powerful as the original DQLTester.
    My favourite is DQLTester, but it doesn't work anymore with Documentum 16.x.

    Pedro Maia
    Senior Consultant
    OpenText

  • Thank you guys. dqman runs, but inadvertently keeps crashing.
    Reg. dql buddy, I will take this up with the Informed for Support.

    DQL Tester FX, yes Pedro agree with you - very slow and nowhere close to what the older one was .



  • PedroMaiaPedroMaia Senior Consultant (OpenText) EM
    Please, publish your findings (for instance regarding DQL Buddy) as it may help others.

    Pedro Maia
    Senior Consultant
    OpenText

  • I had some strange error while running DQL Buddy and found it was related to using DQL Buddy from a folder path which contained space.  I simply copied over to C drive and found it working after that.  Not sure if this is the same error you are facing.
  • PedroMaiaPedroMaia Senior Consultant (OpenText) EM
    MohamedYousuff, the error you experienced might have been something different, as I have no spaces in the path to the 'DQL Buddy' folder and still get the error:
    java.lang.NullPointerException
    at com.informedgroup.dqlbuddy.model.utils.ConfigDBUtils.getCategoryItemsList(ConfigDBUtils.java:1051)

    Pedro Maia
    Senior Consultant
    OpenText

  • You mentioned that 'have no spaces in the path to the 'DQL Buddy' folder '.  So, you still have a space in 'DQL Buddy', rename that folder to remove space and retry again.
  • PedroMaiaPedroMaia Senior Consultant (OpenText) EM
    I was just referencing the name of the application:
    - The folder is 'C:\Workspace-ABC\Software\dqlbuddy_1.0.15_beta'
    - The file is 'DQLBuddy.exe'

    Pedro Maia
    Senior Consultant
    OpenText

  • Can you keep the path simple like c:\dqlbuddy
    The reason for suggestion is characters like _ . and other numericals.  I am not sure if this is exactly what is causing trouble in your case but trying to keep it simple like how I had in my PC and it worked in my case.

  • PedroMaiaPedroMaia Senior Consultant (OpenText) EM
    I tried 'C:\dqlbuddy' and it still fails with the same error. Thank you for the suggestion anyway.

    Pedro Maia
    Senior Consultant
    OpenText

  • Hi PedroMaia,

    We will have a look at it. Can you tell me what version of Documentum and Windows you are running?

    Jeroen
  • Hi Pedro,

    I have looked into your problem. Something seemed to be corrupt in version 1.0.15_beta of DQLBuddy that was uploaded to our site. I have uploaded a new version (1.0.18) which should solve your problem. Please let me know if you still have issues running DQLBuddy.

    Jeroen Teeling
  • PedroMaiaPedroMaia Senior Consultant (OpenText) EM
    Hi Jeroen J. and Jeroen T.,
    I downloaded the latest DQLBuddy 1.0.18 and I confirm that this version is working correctly. Congratulations for the tool and thank you very much for looking into the issue.

    Pedro Maia
    Senior Consultant
    OpenText

  • Hi Pedro,
    Thank you for your confirmation. We are also very interested in any bugs that you find or enhancements you would like to see in this tool.
    Cheers, Jeroen
  • Hi Jeoren,
    Could you please share the link to download dqlbuddy (1.0.18)


  • Sure, the link is: https://www.informedgroup.com/dqlbuddy/

    Please let me know what you think, bugs you find or any enhancements you would like

    Cheers, Jeroen
  • Thanks Jeoren.  I am getting link for version 1.0.15_beta . I need the one you mentioned in the above post. version - (1.0.18)
  • That is strange, I will look into this
  • with beta version, repository list is not populating on connection screen. getting below error.
    [main] ERROR ConfigDBUtils  - org.sqlite.SQLiteException: [SQLITE_ERROR] SQL error or missing database (no such table: APPIMAGE)
  • edited September 8
    Thing is, in the 1.0.15_beta version the embedded database is corrupt, therefor it does not work. I will let you know when the download link refers to the correct version (1.0.18) again

  • The link to version 1.0.18 has been restored, you should be able to download it now. You can use the download link you received in your e-mail (so no need to go to the Informed Group site again)
  • Thank you. Jeroen. I am able to download 1.0.18 and successfully connected to repository as well. 
  • Hi Jeroen,
    I tried the latest version 1.0.18.  In the monitor workflow function, choosing any of the filter option displays the below error message,

    [DM_QUERY_E_BAD_QUAL]error:  "The attribute qualifier, wr, for attribute r_act_seqno, is not a valid qualifier."
    com.informedgroup.dqlbuddy.model.exception.ModelException: [DM_QUERY_E_BAD_QUAL]error:  "The attribute qualifier, wr, for attribute r_act_seqno, is not a valid qualifier."

     at com.informedgroup.dqlbuddy.model.workflow.WorkflowModel.getWorkflows(WorkflowModel.java:418)

     at com.informedgroup.dqlbuddy.model.workflow.WorkflowModel.refreshWorkflows(WorkflowModel.java:741)

     at com.informedgroup.dqlbuddy.gui.WorkflowTab.refreshWorkflows(WorkflowTab.java:769)

     at com.informedgroup.dqlbuddy.gui.WorkflowTab.access$600(WorkflowTab.java:58)

     at com.informedgroup.dqlbuddy.gui.WorkflowTab$QueryWorkflowsListener.widgetSelected(WorkflowTab.java:86)

     at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:252)

     at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:89)

     at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4173)

     at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1057)

     at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3986)

     at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3585)

     at com.informedgroup.dqlbuddy.gui.ExceptionDialog.open(ExceptionDialog.java:129)

     at com.informedgroup.dqlbuddy.gui.ExceptionDialog.<init>(ExceptionDialog.java:61)

     at com.informedgroup.dqlbuddy.gui.DQLBuddyApp.propertyChange(DQLBuddyApp.java:1455)

     at java.beans.PropertyChangeSupport.fire(PropertyChangeSupport.java:335)

     at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:327)

     at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:263)

     at com.informedgroup.dqlbuddy.model.message.MessageModel.setError(MessageModel.java:78)

     at com.informedgroup.dqlbuddy.gui.WorkflowTab.refreshWorkflows(WorkflowTab.java:772)

     at com.informedgroup.dqlbuddy.gui.WorkflowTab.access$600(WorkflowTab.java:58)

     at com.informedgroup.dqlbuddy.gui.WorkflowTab$QueryWorkflowsListener.widgetSelected(WorkflowTab.java:86)

     at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:252)

     at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:89)

     at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4173)

     at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1057)

     at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3986)

     at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3585)

     at com.informedgroup.dqlbuddy.gui.DQLBuddyApp.main(DQLBuddyApp.java:141)

  • Hi Mohamed,

    We will look into that. I'll let you know when we have found what is going wrong.

    Jeroen

  • Hi Mohamed,

    I just did a test myself on DQLBuddy but I am not getting any error from the workflow tab filtering. From your recent download, do you use the db_defaultprofile.db file that was in the zip, or do you use the one from your older DQL Buddy copy? Please make sure the use the one from the 1.0.18 zip file, as this file holds the queries used on the workflow tab.

    If it doesn't work, please let me know.

    VBR,

    Ernst Dijkstra  (developer DQLBuddy)
    InformedGroup

Sign In or Register to comment.