DQL script error adding rights in Documentum

I am running the following query

update dm_folder objects set acl_name='StatusReports' set acl_domain='admin' where folder('/Information Technology_new/PMO/Programs/project/Status Reports',descend) and acl_name<>'StatusReports'

I get the following error:

Error occured during query execution  :[DM_QUERY_F_UP_SAVE]fatal: "UPDATE: An error has occurred during a save  operation."

[DM_SYSOBJECT_E_CANT_FETCH_ACL]error: "Failed to fetch the  ACL 'StatusReports' in domain 'admin' for dm_folder 'Vigiliance'.  [ProcessACL]"

[DM_ACL_E_CANT_FETCH_ACL]error: "Failed to fetch the ACL  'StatusReports' in the domain 'admin'."

Anyone have any idea why that would happen? I have done this many times before with no issue.

Best Answer

  • edited July 13, 2010 Accepted Answer

    The system seems to believe the acl_domain / acl_name combination doesn't exist.  Are you sure you're not missing a space or underscore in "StatusReports"?  Try checking with something like: select object_name, owner_name from dm_acl where object_name like 'Status%' and owner_name='admin'.

Answers

  • edited July 13, 2010

    Thanks! I was spelling it write, but for whatever reason it was not finding the ACL. It was new so I deleted it and made a new one, and it then worked.

  • edited January 23

    I tried deleting and creating again. But it also did not worked.

Sign In or Register to comment.