Relation types

I've created a Relation Type in a project in Composer 6.7sp1. Parent type is a custom type and the Child type is the same custom type. I've installed the project, watching the installation progress. The relation type was installed and I verified so by querying for the dm_relation_type in DA. The issue is when I right click on an instance of custom type, select 'Add Relationship', navigate to a 2nd instance of custome type, click Next on the wizard, I don't see my relation type in the dropdown. All I see is 'peer'. I also bounced the webtop tomcat instance prior to invoking 'Add releation' to ensure the data dictionary and cache is refreshed.

1) Can anyone assist in troubleshooting this issue?

2) Is there additional documentation or forum articles on relation types that one could point me to?

thanks,

Peter

Comments

  • edited October 5, 2012

    1) Did you select instance of the child type before clicking "Add Relationship"?

    2) Most of the documentation is in the Content Server Fundamentals and Object Reference Manual

  • edited October 8, 2012

    Johnny, yes I have selected the child type. The sequence of steps is as follows:

    1) In webtop, right click on the 1st of the objects participating in the relationshipd (parent), and select 'Add relationship'

    2) This lauches the Add relationship wizard. Navigate to the child object in the wizard and select it. This results in the 'Choose a relationship' dialog. There is a 'Relationship' dropdown, and a free form text box 'Description'. The drop down only has a single value in it's list: 'peer'

    I will review the manuals you suggest, but it is a straightforward process, so I believe that the relationship type, while it is in the repository, is not being recognized for some reason.

    Thanks,

    Peter

  • edited October 8, 2012

    You can perform API dump on your dm_relation_type object

  • edited October 8, 2012

    Johnny, I did this. See below.

    API>dump,c,380f429f80003100

    ...

    USER ATTRIBUTES

    relation_name : Ind Cntrct P-toC

    security_type : PARENT

    parent_type : staples_indirect_contract

    child_type : staples_indirect_contract

    description :

    direction_kind : 0

    integrity_kind : 0

    parent_child_label : ParentToChild lbl

    : ParentToChild lbl2

    child_parent_label : ChildToParent lbl

    : ChildToParent lbl2

    permanent_link : T

    copy_child : 0

    SYSTEM ATTRIBUTES

    r_object_id : 380f429f80003100

    APPLICATION ATTRIBUTES

    a_controlling_kind : cont. kind fld

    INTERNAL ATTRIBUTES

    i_is_replica : F

    i_vstamp : 2

    Thanks,

    Peter

    303 664 2208

  • edited October 8, 2012

    Try adding description value (eg Ind Cntrct P-toC) to dm_relation_type object.

  • For whatever it is worth, I ran into this and discovered that I had to set the a_controlling_kind attribute to the value 'External' for the relation type to appear in the dropdown in Webtop and Administrator

  • Good to know. Thanks for posting your findings back to the community

Sign In or Register to comment.