Welcome and thank you for joining our new OpenText forum. Your questions, responses, best practices, and tips shared with other members will help make this channel vibrant. We're glad you're joining us and look forward to collaborating with you online.

Check out the Getting Started With OpenText Forums for tips on personalizing your experience.

Getting NULL column(Date = 01/01/0001) in Crosstab. How to remove it?

Hello,
Good evening!

I am getting a null additional column (Null column header displays - '0/0/0001') in the start of the crosstab in which one group(column) displays the months from Jan - Dec by considering the input date parameters "Start Date" and "End Date". I have tried by giving conditions to hide the column in the javascripts but only the column header is becoming empty not the Whole column. Could anyone please help me how to hide that particular column. Please view the snapshot attached below for your review. Thanks in advance.

Thanks,
Sai

Thanks & Regards,
Sai

Best Answer

  • Accepted Answer

    It's possible to create a visibility rule, but it would be better to fix the data eliminating the empty rows. Modify the query if the source is a DB. If not, create a filter in the data set.

    Jeff F.
    Customer Support Engineer I
    OpenText

Answers

  • Can you help answer this question?

    We have noticed this question is over 30 days old and hasn't received a response. We're turning to you, the community, to help answer it.

    This generic response is intended to prompt discussion in this post. The question remains open to your answers, suggestions, and best practices.

    If you posted this question, what additional information can you provide to help us respond to you? Were able to resolve the issue? Please share your solution here with others. If you still need additional help, though, please let us know. Your question and its resolution are important to us, and we want to help.

    • Please note that questions to the developer network are typically peer-to-peer, best effort responses.
    • Additionally, note that posting questions to General may not be answered by a product expert. The General forum is for non-product questions. Please be sure to post your product-specific questions to the proper product forum.

    David Sciuto

  • @jfranken said:
    It's possible to create a visibility rule, but it would be better to fix the data eliminating the empty rows. Modify the query if the source is a DB. If not, create a filter in the data set.

    Hello Jeff,

    I have combined multiple datasets using Join Dataset concept in Actuate which includes the Month Dataset(which displays only months). I have developed all the report when it was working. When there are was addition of data in the database, from then the getting this Null data additional column at the start of the crosstab. I believe because of that Month Dataset this error was happened.

    Thanks,
    Sai

    Thanks & Regards,
    Sai
  • Hi Sai,

    There was another post about joining data sets. If I remember correctly, you wanted to do a union, but you couldn't do it in the query and you weren't using a version of the Designer that supports unions, so I helped you do a workaround with multiple joint data sets.

    Even if you have multiple joint data sets, you should still be able to add "where" clauses to the original data sets to filter out the data that is causing the column of zeros to be created. Is there are reason why you are not able to add "where" clauses?

    There could also be an issue with the column grouping, but I can't tell how you are grouping from the screenshot. Also, you said that new data caused the first column to appear which leads me to believe that altering the query is the correct option if you are able to do so.

    Jeff F.
    Customer Support Engineer I
    OpenText
Sign In or Register to comment.