HTML5 Line Chart Tool Tip Problem

When I use HTML5 as the output format, the tool tips display incorrect results (see the attached Image)

However, when I switch to SVG, I get the tool tip results I'm expecting. In this case it should be 2.

Comments

  • By default, the tooltip text should display the series value for chosen the data point. In the chart editor, go to the Script tab and select the series with the issue in the left pane. In the properties on the right, choose the "Mouse Over" event and the "Show Tooltip" action. Is there code in the "Tooltip Text" expression that is overriding the default behavior? Is it returning the correct data?

    Jeff F.
    Customer Support Engineer I
    OpenText
  • @jfranken said:
    By default, the tooltip text should display the series value for chosen the data point. In the chart editor, go to the Script tab and select the series with the issue in the left pane. In the properties on the right, choose the "Mouse Over" event and the "Show Tooltip" action. Is there code in the "Tooltip Text" expression that is overriding the default behavior? Is it returning the correct data?

    Thanks Jeff. I just looked and there's no code there.

  • Maybe it is a client script. On the Script tab, try selecting "Client Script" in the left pane. "Client script" is only displayed when the chart type is set to HTML5. It actually makes more sense that the code to modify the tooltip is part of the Client script. It explains why only the HTML5 chart is affected. Here is the corresponding Highcharts reference with a few examples:

    https://api.highcharts.com/highcharts/tooltip.formatter

    If you don't see the tooltip code in the Client Script editor, perhaps you could post your report or a sample report that replicates the issue.

    Jeff F.
    Customer Support Engineer I
    OpenText
  • @jfranken said:
    Maybe it is a client script. On the Script tab, try selecting "Client Script" in the left pane. "Client script" is only displayed when the chart type is set to HTML5. It actually makes more sense that the code to modify the tooltip is part of the Client script. It explains why only the HTML5 chart is affected. Here is the corresponding Highcharts reference with a few examples:

    https://api.highcharts.com/highcharts/tooltip.formatter

    If you don't see the tooltip code in the Client Script editor, perhaps you could post your report or a sample report that replicates the issue.

    I don't see a client script on the script tab. Let me see if I can mock this up with sample data and post the design.

Sign In or Register to comment.