Report Visibility

Hi All,
I have a report with 3 charts A, B, C and I want to have 3 tabs/lables/parameters Aa, Bb, Cc( not sure which one is best to use ) on the report
and then be able to select As tabs/lables/parameters to only present chart A and same for B and C,
what is the best approach for that ? and if you have any sample report I will appreciate it if you could share.

thanks

Comments

  • edited March 18

    I don't completely understand the requirement. What is the criteria for deciding what will be displayed? Does the user pick a chart type to view? If so, add a parameter. Select each chart on the report. Go to the Properties tab for the chart and choose "Visibility". Check the "Hide Element" box for all the charts. Add a visibility rule for each chart, i.e. for chart "A":

    if (params["insert_param_name"].value = "A") true

    Jeff F.
    Customer Support Engineer I
    OpenText
  • Hi Jeff,
    I have created 3 parameter and linked them to each chart so when user select parameter from drop down they can see related chart but what I want to do it to apply the 3 choices in the report hear so instead of drop down parameter they can select the option within report,
    thanks

  • Thanks for the clarification. BIRT is a pure reporting tool. The only interaction is via parameters. However, if you place a Text element on the report and change its type to HTML, you can add custom HTML. That includes script tags to insert JavaScript. One tip is that adding a Bookmark property to an element gives it an ID with the Bookmark value. The Bookmark makes it easier to reference elements in JavaScript.

    Jeff F.
    Customer Support Engineer I
    OpenText
  • Thanks Jeff

  • Attached is a simple example that hides/shows the chart by the bookmark ID (created in 4.8).

    Jeff F.
    Customer Support Engineer I
    OpenText
  • Thanks Jeff,
    I have tried to click, Ctrl/Alt click, Shift Alt click but it is not doing much, am I missing anything?
    cheers

  • edited March 19

    Go to the Window menu in the designer and select Preferences. Under "Report Design" in the left pane, click "Preview". At the bottom of the right pane is a checkbox labeled "Always use external browsers". Make sure it is checked. Directly beneath it is a "Web Browser" link. Click it (or go to General > Web Browser in the left pane). Choose or add the browser you would like to use to test. Save the changes.

    Try previewing again by going to the Run menu and selecting View Report > In Web Viewer. Do the buttons work when you click them? If not, maybe a browser setting is preventing the JavaScript from running. Test in a different browser if you have more than one.

    Jeff F.
    Customer Support Engineer I
    OpenText
  • Thanks Jeff, I will Test it on different web browsers

Sign In or Register to comment.