Integrating BIRT 4.8 into Wildfly 15 with Java 11

I have an integrated Birt Runtime 4.6 in my Wildfly 10 setup running Java 8 and I'm trying to upgrade to BIRT 4.8 in Wildfly 15 and Java 11.

The reports are running fine but when I have any SVG graphics in my report (charts, backgrounds) I get a Linkage error which tells me I'm trying to use a module already previously loaded by birt, "org.w3c.css.sac.jar"

I've tried running Birt Runtime 4.8 in Wildfly 15 with Java 11 on it's own, but in conjunction with my other environment I'm trying to integrate into I get this problem.

Anyone run into anything similar or could suggest any solutions?

Sign In or Register to comment.