Dqman initial load time

Does anyone know how to prevent dqman from loading the first 2000 groups, the first 5000 users, and every single cabinet at startup? With over 120,000 cabinets, it takes over 2 minutes just to start a session because of the above.


  • dqMan is a fme tool and not documentum tool, though it helps in querying the Documentum docbase.

    Rohanna Dodla
    Subject Matter Expert (SME), Documentum


  • @DCTM_OT said:
    dqMan is a fme tool and not documentum tool, though it helps in querying the Documentum docbase.

    I'm quite aware of this. While I appreciate you taking the time to comment, I don't see how it helps. I'm not even remotely the first one to post here about dqman as it's used quite universally given the lack of an "official" counterpart to same. For that matter, a number of OpenText folks use it (as indicated in various posts throughout the forum) and there's even a support note about it.

  • edited April 26

    I think what Rohanna is trying to say is that unless you have source code, this isn't something you can change. I don't recall seeing any documentation on dqMan that talks about about start up parameters you can set.

  • Yes, that's true, given the usage of it in Documentum with dqMan, many have assumed the obvious.

    Rohanna Dodla
    Subject Matter Expert (SME), Documentum


  • Well, FWIW, it appears that either some things cached or setting some options (like hiding private cabinets) has significantly improved the session start time.

  • Probably hiding private cabinet fixed your issue. If it was a caching issue, you would probably see it again the next time you run dqMan.

  • edited May 9

    Hi there,

    the session startup queries are stored in the (dqMan home)\config\dqManDQLHelp.xml file.

    You can edit the queries in the <queries> section:

    <query id="dm_type">select distinct name from dm_type order by name</query>
    <query id="dm_registered">SELECT distinct object_name from dm_registered WHERE object_name NOT like '%_s' ESCAPE '\' and object_name NOT like '%_r' ESCAPE '\' ORDER BY object_name</query>
    <query id="dm_group">select distinct group_name from dm_group order by group_name enable(RETURN_TOP 2000)</query>
    <query id="dm_user">select distinct user_name from dm_user WHERE r_is_group=0 ORDER BY user_name enable(RETURN_TOP 5000)</query>
    <query from="6.0" id="dmc_aspect_type">select distinct object_name from dmc_aspect_type ORDER BY 1 enable(RETURN_TOP 5000) </query>

    If you remove a query please check where it is referenced (by ID) in the <dynamic> section of the same XML. Maybe, you Need to remove the referncing value assistance.

Sign In or Register to comment.