Demo toolbox xCelerator 16.4.1

Hi All,
How could I download the Demo toolbox xCelerator for XCP 16.4.1? if it is not there yet, I understood from other posts that it worked after removing the jars and javamodules, so I removed all the folders from the demo toll box jar except "DemoToolbox" and the "manifest", then I changed the manifest file to be as below, the problem is that in the "Add Library" dialog the checkbox beside the library is not clickable to select the library, any help?

Manifest-Version: 1.0
Ant-Version: Apache Ant 1.8.3
Created-By: 1.6.0_37-b06 (Sun Microsystems Inc.)
Built-By: burnec3
Component-Bundle: DemoToolbox
Require-Bundle: xcpcore, xcpcommons
Bundle-Version: 16.4.1
Bundle-ManifestVersion: 2
Bundle-Name: Demo Toolbox
Bundle-SymbolicName: dtb.DemoToolbox
NAMESPACE: dtb
EMC-XCP-ExecutionEnvironment: com.emc.executionenvironment.xcp:16.4.1

Comments

  • Try changing the execution environment to EMC-XCP-ExecutionEnvironment: com.emc.executionenvironment.xcp:16.4.1000

  • Thank you Paulo for your reply, it worked with me using

    com.emc.executionenvironment.xcp:16.4.1000.0047

    However many forms were not opening in the designer, I removed many custom widgets from the library and kept only what I used, also I removed the Java module folder as described in another post, thank ****, the forms opened in the designer and the war was generated.
  • Hi Khaled

    Out of interest which custom widgets did you want to retain & which ones did you end up removing? I'm faced with exactly the same issue. I just need to use the dtb_button (specifically the ability to open link from expression in new tab). I've been hacking about with the DTB JAR. The functions appear to work in the 16.4.1. It's just the widgets that appear to be problematic.

    Cheers

    Mark

  • s_vaidyas_vaidya Samir Vaidya EM

    @mark.davidson, if you just want to open a URL in new tab using button, then you can use regular Button in xCP. It supports opening URL (built using expressions) and also opening the URL in new tab.

    Samir Vaidya
    Enterprise Software Architect
    OpenText

  • Hi Mark,
    I removed many problem causing widgets (including the dtb_button) from the library, then I removed the dtb_buttons from all the forms and used the standard XCP designer buttons.

    My best regards,
    Khalid

Sign In or Register to comment.