Persian characters showed separately in PDF generated using BIRT

I've developed a report using the BIRT Report Designer RCP 4.8.0. I've built a report contains some Persian (or Farsi) texts. The designer show my Persian texts correctly, but when I rendered the report in PDF format, some Persian characters are incorrect. The generated PDF file doesn't show special Persian characters which are not same as Arabic characters. There are some common characters in Arabic and Persian which has different shapes in two languages and also Persian has 4 more characters than Arabic. When I see the report in PDF format some characters showed separated. Also I apply some settings to fontsConfig.xml file and these fonts apply to the generated PDF file, but as I mentioned there are a problem with some special Persian characters that doesn't exist in Arabic.
I checked the https://forums.opentext.com/forums/discussion/comment/162305 link, but it cann't help me and there are some links to some source codes that was broken.

How can I fix this problem?

Comments

  • I did a search and saw some discussion online about the Acrobat PDF reader causing issues similar to the ones you are describing. I don't know if those comments were correct, but it should be simple to test a different reader if you are using Acrobat.

    Jeff F.
    Customer Support Engineer I
    OpenText
  • Thank you for your reply.
    I did many test with other reader apps and all fo them had the same problem.

  • If the reader is not causing the issue, I recommend reporting it on: https://bugs.eclipse.org/bugs/

    Jeff F.
    Customer Support Engineer I
    OpenText
Sign In or Register to comment.