Not able to debug the report

I am trying to debug the report(debug as configuration, jre 1.8_192) in open text analytics designer. My reports has parameter with default value. I am getting below NPE in error log. Please help to resolve this issue.

org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)
at org.eclipse.swt.SWT.error(SWT.java:4533)
at org.eclipse.swt.SWT.error(SWT.java:4448)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4032)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3708)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1121)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1022)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:150)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:693)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:610)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:138)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
at org.eclipse.equinox.launcher.Main.run(Main.java:1519)
Caused by: java.lang.NullPointerException
at org.eclipse.birt.report.engine.api.impl.GetParameterDefinitionTask.getDefaultValue(GetParameterDefinitionTask.java:338)
at org.eclipse.birt.report.designer.ui.parameters.ScalarParameter.getDefaultValues(ScalarParameter.java:202)
at org.eclipse.birt.report.designer.ui.dialogs.AbstractParameterControlHelper.getPreSetValue(InputParameterDialog.java:528)
at org.eclipse.birt.report.designer.ui.dialogs.AbstractParameterControlHelper.prepareControlDefaultValue(InputParameterDialog.java:515)
at org.eclipse.birt.report.designer.ui.dialogs.AbstractParameterControlHelper.init(InputParameterDialog.java:503)
at org.eclipse.birt.report.designer.ui.dialogs.AbstractParameterControlHelper.createControl(InputParameterDialog.java:404)
at org.eclipse.birt.report.designer.ui.dialogs.InputParameterDialog.createParamSection(InputParameterDialog.java:271)
at org.eclipse.birt.report.designer.ui.dialogs.InputParameterDialog.createParametersSection(InputParameterDialog.java:209)
at org.eclipse.birt.report.designer.ui.dialogs.InputParameterDialog.createParametersSection(InputParameterDialog.java:220)
at org.eclipse.birt.report.designer.ui.dialogs.InputParameterDialog.createParameters(InputParameterDialog.java:194)
at org.eclipse.birt.report.designer.ui.dialogs.InputParameterDialog.createDialogArea(InputParameterDialog.java:175)
at org.eclipse.jface.dialogs.Dialog.createContents(Dialog.java:767)
at org.eclipse.jface.window.Window.create(Window.java:426)
at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1095)
at org.eclipse.birt.report.designer.ui.dialogs.BaseDialog.open(BaseDialog.java:107)
at org.eclipse.birt.report.debug.internal.ui.script.launcher.ReportLaunchHelper.getParameterValues(ReportLaunchHelper.java:326)
at org.eclipse.birt.report.debug.internal.ui.script.launcher.ReportLaunchHelper.access$2(ReportLaunchHelper.java:319)
at org.eclipse.birt.report.debug.internal.ui.script.launcher.ReportLaunchHelper$1.run(ReportLaunchHelper.java:417)
at org.eclipse.ui.internal.UILockListener.doPendingWork(UILockListener.java:162)
at org.eclipse.ui.internal.UISynchronizer$3.run(UISynchronizer.java:154)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
... 23 more

Comments

  • This is a known bug that has been patched in the commercial version (BIRT-4641). Please open a support ticket if possible.

    Jeff F.
    Customer Support Engineer I
    OpenText
  • edited July 1

    Thanks for your response. Please confirm, you will be provide updates for open text analytics designer eclipse. I am using this on my mac.Open text report designer tool version on my mac is
    OpenText Analytics Designer
    Version: 24.4.0
    Build id: v20180424

    How can I know which birt version is there for Open Text Designer Eclipse on my mac?

    Dev ops team will open a support ticket to get patch.

  • For the support ticket, the following information will be helpful:

    Issue Description: When attempting to debug a report with a parameter that has a default value, I get the error, "org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)". I was told on the OT forums that this issue might be related to BIRT-4641 and there might be an existing patch.

    OS: Mac (give OS version if possible)
    Product: Analytics Designer - Build id: v20180424

    Jeff F.
    Customer Support Engineer I
    OpenText
Sign In or Register to comment.