metatagger de-limiter

When we are using MetaTagger to set MetaData on a file, there are instances where multiple values can be selected. By default, MetaTagger uses the comma as the delimiter for multiple values, but we would like this to be a semi-colon. Is there are easy way to make this configuration?

Any thoughts on this one would be well received. We are try to avoid having to use post processing on this one...

Thanks.

Lucas Cochrane
[email protected]

Comments

  • I understand that this is an item that is configured in metatagger.cfg. Has anyone dealt with this configuration before?

    Thanks.

    Lucas Cochrane
    [email protected]
  • Here is how you can configure the delimiter. Create an XML file called "mdstore.cfg" containing this:

    <config>
    <output>
    <valueSetSeparator>;</valueSetSeparator>
    </output>
    </config>

    Now you need to put this file into the directory pointed to by the "DB_HOME" environment variable and this needs to be done on the machine running TeamSite (as opposed to the machine running Metatagger in a 2 machine setup).
  • FYI,
    DB_HOME is usually <iw-home>/metatagger/conf
  • your first post has confused me a little. I put this file in <iw-home>/metatagger/conf - but this is not a directory on out TeamSite server, only our MetaTagger server. Should I create it?

    Thanks.

    Lucas Cochrane
    [email protected]
  • I'm assuming you're using either the Metatagger capture GUI or iwmtbatch or both. Since these clients run on the TeamSite machine we need to put the config file there. I was told that the installer creates the DB_HOME directory even when you just install the MT-TS extensions on the TS machine, but maybe this is not the case. If DB_HOME does not exist you need to do this:

    1. Create a directory and put the mdstore.cfg file in it.

    2. Set the DB_HOME environment variable. If on Windows you just set a system wide environment variable that points to your directory. If on Solaris you need to set it in the shell that you use to run "iwreset -ui" or iwmtbatch.
  • I absolutely cannot get this functionality to work for MetaTagger, am I missing something here. Does the xml file need to be on the Metaggaer server too?

    Thanks.

    Lucas Cochrane
    [email protected]
  • It works for me. Don't forget to do an "iwreset -ui" after creating the new config file.
Sign In or Register to comment.