WSW Enhanced Browse Dialog - Permission denied

I'm trying to access WSW enhanced browse dialog from a different server. I'm able to lanuch the dialog and select the document but couldn't get the callback function to work (it doesn't get invoked) because of the same origin policy. Setting document.domain doesn't seem to work. 

 

WSW server - http://workstieweb/worksite

Calling app server - http://webserver/app

 

Any suggestions?

Comments

  • Are the servers on the same domain? can you use the FQDN i.e http://workstieweb.mydomain.com/worksite

    and http://webserver.mydomain.com/app? This should help with the document.domain feature. Other option is install a local istance of worksite web on the webserver, that's what HP do for IUS's worksite intergration

  • Thanks for the reply. Tried the FQDN route to no avail. I could try installing Worksite web on the web server but I need this functionality on several web servers and it might not conducive to do so on every single server. Any other suggestions?

  • Hmm. Sorry, none spring to mind.  DO you need to use the browse dialog? could you impliment your own talking to the worksite server using the SOAP or REST or even the direct API?

Sign In or Register to comment.