Running several jobs at the same time

Hi everyone,


 


Is it possible to execute several scheduled jobs in iHub at the same time? I scheduled a reportdesign once a day that needs 20 minutes for execution. While this report is executing all other scheduled jobs are added to the list of pending jobs.


 


 


Comments

  • Dennis,


     


    This is dependent entirely on the license and configuration of the iHub.


    If your license has more than 1 Factory work unit, or is a CPU based license you can modify the acserverconfig.xml file to increase the maximum number of factories that can run.


     


    Please let me know if this is something that you need some additional information or help on.


    Thanks!

    Ryan Siegler
    OpenText Support
    http://www.opentext.com

     

  • Hi Ryan, 


     


    Thanks for your reply. I have a CPU based license with a core limit of 2. How do I have to modify the acserverconfig.xml to increase the maximum number of factories?


  • Dennis,


     


    At the bottom of the acserverconfig.xml file (typically found at $AC_SERVER_HOME$/shared/config/) there is a block titled "ServerList".


    In this list you should see your node, and what template it uses.


     


    In the template section (second secondary section of the file), look for the template specified at the bottom of the config.


    Within that template's block, find the BIRT Factory resource group and modify similar to below, as the default MaxFactory value is one:


    <ServerResourceGroupSetting

    Name="Default BIRT Factory"

    Activate="true"

    MaxFactory="2"

    StartArguments="-Xmx2G -XX:MaxPermSize=256m -XX:-UsePerfData -Djava.awt.headless=true -Djava.net.preferIPv4Stack=true -Djava.protocol.handler.pkgs=com.actuate.javaserver.protocol com.actuate.javaserver.Server"/>

     

    Save the file, then start the iHub service again.

    Ryan Siegler
    OpenText Support
    http://www.opentext.com

     

  • Hi Ryan,


     


    I edited the config file and restarted iHub service. But still the same problem. I only get one job my list of active jobs at once.


    Is there maybe a problem in my schedule configuration?


  • Dennis,


     


    Could you check the acpmdconfig.xml file (located at $AC_SERVER_HOME$/etc/) for the value of the AC_CONFIG_HOME and search for the word template?


     


    Please post both of those into a reply, and upload a copy of the acserverconfig.xml file (with any IP addresses and server names removed, please).


     


    I'd like to take a quick peek at this as manual editing of the xml file can be like trying to hunt down the missing semi-colon in a java application.


    Ryan Siegler
    OpenText Support
    http://www.opentext.com

     

  • Hi Ryan,


     


    here the value of AC_CONFIG_HOME:



    <EnvironmentVariable Name="AC_CONFIG_HOME" Value="D:/BIRTiHubVisualization/modules/BIRTiHub/iHub/shared/config"/>

    The only time I could find the word template was here:




    <Service Name="BIRT" Description="BIRT based Data Visualization Services" DisplayName="BIRT" StartupType="Auto">
        <Property Name="CapacityTemplate" Value="large"/>
    </Service>

  • Dennis,


     


    Insert a line between lines 296 and 297 in the acserverconfig.xml file.


    Insert the following text:


    MaxFactory="2"


     


    This should allow for 2 Asynchronous factories to run simultaneously so long as the system has sufficient resources (CPU and RAM).


     


    The change in entry that you modified to 2 was in the "disable" template.


    Please let me know if you run into any issues with the process.


    Thanks!


    Ryan Siegler
    OpenText Support
    http://www.opentext.com

     

  • Hi Ryan,


     


    it works! Thanks for your help!


  • Dennis,


     


    Glad to hear it!


    Hope that helps you in finding the right balance for factories to the system resources.


    Ryan Siegler
    OpenText Support
    http://www.opentext.com

     

  • Hi Ryan,


     


    yes it works much better now.


    Thanks for the great support.


Sign In or Register to comment.