Security issues with BIRT

Good day. Recently, I've notice that the following JAR APIs embedded into the BIRT framework have security vulnerabilities and exposures opened against them.


Do you have any plan to address these security issues? Thanks a lot in advance.

 


axis.jar

CVE-2012-5784

CVE-2014-3596

 

derby.jar

CVE-2009-4269

CVE-2015-1832

 

org.apache.batik.css_1.6.0.v201011041432.jar

CVE-2015-0250

 

org.apache.batik.pdf_1.6.0.v201105071520.jar

CVE-2015-0250

 

org.apache.poi_3.9.0.v201303080712.jar

CVE-2014-3529

CVE-2014-3574

CVE-2014-9527

CVE-2016-5000

CVE-2017-5644

 

org.eclipse.birt.report.data.oda.excel_4.4.1.v201408290142.jar: poi-ooxml-3.9-20121203.jar 

CVE-2014-3529

CVE-2014-3574

CVE-2014-9527

CVE-2016-5000

CVE-2017-5644

 

poi-ooxml-3.9-20121203.jar 

CVE-2014-3529

CVE-2014-3574

CVE-2014-9527

CVE-2016-5000

CVE-2017-5644



 


Comments

Sign In or Register to comment.