How to migrate LiveSite Runtime to another server - copy or re-publish all

Hello,
looking for opinions...

I've copied another content-store into my TeamSite server and it's working fine within TeamSite. Just had to copy over templating.cfg, as most other things (workflows, custom menu items) were bog standard.

Now I'm wondering what to do about the Runtime. Is it best to:
a. copy over LiveSiteDisplayServices/runtime/web/ and LSCSRT-Store ? (Anything else?)
b. blow away existing LiveSiteDisplayServices/runtime/web/ and LSCSRT-Store, and re-publish everything from the new content store
c. just leave as is and re-publish

This isn't a Production server, it's just a demo server for developing content with everything on it (TS, LS, Indexer), so as long as it all hangs together it's fine. Given that, is there anything else I've missed?

Cheers
BB

Comments

  • You can copy LiveSiteDisplayServices/runtime/web/ but need to redeploy LSCS. Copying the store won't cut it.

    I always write a deploy_all script for LSCS for stuff like that.

  • Hi Andy,
    when you say "redeploy LSCS", can I just delete current contents of LSCSRT-Store and use the Publish LiveSite Content workflow to repopulate it per branch, or are you talking about uninstalling/installing LSCS runtime?

    This is the first time I've actually used LS runtime, so still coming to grips with it. Wondering what was in LSCSRT-Store initially, didn't check.

  • You cannot just delete content in LSCSRT-Store. Don't do it.

    You can drop the project. curl http://LSCSTR-server:1876/lscs/v1/projects/my-project-name?method=DELETE

    PLC would work, however if you have a lot of data that is a pain. There is a script (wherever yours is located):

    /opt/Interwoven/LiveSiteCSAuth/authoring/bin/startdeploy.sh --help

    Runs something like this

    sudo /opt/Interwoven/LiveSiteCSAuth/authoring/bin/startdeploy.sh -StartDeploy_DeploymentMode prod-lscs -StartDeploy_OverrideManifest /opt/Interwoven/TeamSite/tmp/manifest.xml

    Learn to use that, the manifest is an XML like:

    <?xml version="1.0" encoding="UTF-8"?>




    2018-02-23 14:44:21


    2018-04-03 15:08:12


    Note: PLC adds LatestModifiedDate but startdeploy does not, so this is how I set it. We use it in our queries. You can skip the attribute statement completely if you don't need it.

    Andy

  • Try again, the forum software does not like XML

    < ?xml version="1.0" encoding="UTF-8"? >
    < deployment >
    < context area="/default/main/myproj/STAGING/" />
    < filelist >
    < file areaRelativePath="templatedata/proj/content/data/home.xml" otherAttributes="true" >
    < attribute name="LatestModifiedDate" >< value >2018-02-23 14:44:21< /value >< /attribute >
    < /file >
    < file areaRelativePath="templatedata/proj/content/data/test1.xml" otherAttributes="true" >
    < attribute name="LatestModifiedDate" >< value >2018-04-03 15:08:12< /value >< /attribute >
    < /file >
    < /filelist >
    < /deploymen t>

  • Hello, back on this...

    I think this is largely working now, having (re-)published sites, which were quite small.

    I am trying to make sense of it though, as I am not very familiar with the runtime. So I am looking at the deployment target and I see 5 sites (including Component Guide, for example) physically under /usr/Interwoven/LiveSiteDisplayServices/runtime/web/sites/* and you can choose from 5 sites in the URL. Great.

    But I do see some spurious stuff directly under /usr/Interwoven/LiveSiteDisplayServices/runtime/web, like:
    drwxrwxr-x 8 root root 108 Sep 5 12:27 iw/
    drwxr-xr-x 18 root root 230 Sep 18 13:35 iwov-resources/
    -rw-r--r-- 1 pejohnso wheel 32 Sep 6 14:12 NewFile_rootlevel.txt
    drwxr-xr-x 5 root root 54 Sep 18 13:35 templatedata/

    I think these were deployed there before it was working properly, but I am wondering how that could have happened. It's possible a configuration may have been changed by a guy who has just left, so I am trying to figure it out myself. Should everything be under web/sites, and what could cause it to be deployed a directory up?

    Grateful for any insights to aid my understanding of the runtime.

    Cheers
    BB

  • LSDS will not work without iw and iwov-resources. Don't get rid of them. Having the templatedata is a tossup. You can have LSDS components that read the DCR directly or others that query LSCS for that data.

    I would leave them where they are.

    Finally you likely should have some web assets (CSS/JS/digital assets) to be displayed on your site. Those could also be in that directory (or other locations depending on your setup)

  • Thanks Andy.

Sign In or Register to comment.