Error processing command:DfIOException:: THREAD: http-8080-6; MSG: [DM_SESSION_E_RPC_ERROR]error: "


I have tried to fix an issue wrt the workfow workqueue I have been in the final verge of finishing the acquired-assigned work-items tasks in the mv_ais_location_coding_queue from the taskspace app, through legacy prod DA DQL/API
To fix the AIS-app check in case failed issue.

Also, the first thing we he showed me was accessing AIS via TaskSpace via this link:

We logged in using the admin account to our docbase.
Selecting the Queue Management tab then the All Work Queues from the drop down on the far right, we double-clicked the mv_ais_manual_location_queue.
In the new list we first selected Items per Page from 10 to 100 and did a sort by selecting the Status column to bubble up all Assigned items, did CNTRL-A (select all) then using the mouse, chose the button on the right and selected unassign from the popup menu.
We received an error which is indicative that the when the system was updating workflow or queue items, the process did not complete (please don’t actually try to reset the status).
As a result, though the items are listed as being assigned, they are not actually assigned.

Step 1 I have Built a Dynamic DQL statement that selects the impacted objects …. Dynamic SQL is basically command text or string combined with the data you are selecting to form a command in the result set.

**Notice the predicate clause only selects Location Coding workflows and activities with a r_runtime_state = 1 *** My counts match the total records that they state are assigned.

select 'complete,c,' + wi.r_object_id from dm_workflow w, dmi_workitem wi, dm_activity ac where w.r_object_id = wi.r_workflow_id and wi.r_act_def_id = ac.r_object_id and wi.r_workflow_id in (select r_object_id from dm_workflow) and w.object_name like 'Loc%' and wi.r_runtime_state =1


The above Dynamic statement when dumped out to a text file produces the results in the attached file complete.txt, this is what is ran in step 2

Step 2 I have Run the dynamic command. This command is complete,c, which completes the selected work items that are currently acquired.

I have used DA & Documentum Server Manager IAPI to execute this command,

However I’m encountering the error “Error processing command:DfIOException:: THREAD: http-8080-6; MSG: [DM_SESSION_E_RPC_ERROR]error: "Server communication failure"; ERRORCODE: 100; NEXT: null”

I have even tried to execute this API command through IAPI on Documentum Server Manager Console on Legacy Prod CS but encountered the same and [DM_SESSION_Ideadlock_retry]:Retrying Server Operation following a DBMS Deadlock Error
com.documentum.fc.client.impl.connection.docbase.netwise.NetwiseDocbaseRpcClient Deadlock reported by server connection = 0102134180fe40.

DCTM_GURU kindly throw some light to fix this high impack prod issue.

Appreciate your timely response.

Thanks & Warm Regards,


  • I dont you cant use "c" in your api script. This is just a alias. When you create a session, it will return you session ID. This is what should be place in lieu "c".

  • SmelanathurSmelanathur Technical Architect

    What would be the exact api command to execute the task using complete keyword? for all the assigned acquired work-items to finish their tasks form the workqueue? run_time_state attribute value being = 1 for the acquired ones?

  • SmelanathurSmelanathur Technical Architect

    DCTM_GURU please throw some light to execute the command to complete the workflow tasks. The work-items are held up in the work queue and run time state as 1 meaning acquired and not yet finished.

  • SmelanathurSmelanathur Technical Architect

    Dctm_guru please throw some light i have executed the above api command and still the count is 4 for the manual location coding workqueue under assigned-acquired work-items tasks unfinished runtime state for the assigned acquired ones is 1 and i have framed the query in such a way.
    Please throw some light to fix this issue encountered for one work-item task to finish?

    Error processing command:DfException:: THREAD: http-8080-8; MSG: [DM_WORKFLOW_E_MANU_PACKAGE]error: "Failed to manufacture packages for activity 'Manual Location Coding' (5) of workflow (4d02134180a84300)."; ERRORCODE: 100; NEXT: DfException:: THREAD: http-8080-8; MSG: [DM_WORKFLOW_E_BINDING_PACKAGE]error: "Package binding failed because no object could be identified by package ID (0b0213418b5ee9d3) with package label 'CURRENT'."; ERRORCODE: 100; NEXT: null

  • Does this object exist - 0b0213418b5ee9d3? You can define a workflow activity to validate that a document/folder has been associated with package before you complete it.

  • SmelanathurSmelanathur Technical Architect

    Yes the object has to be searched by dql query if it exists in the docbase? how to trace the missing workflow instances and queue management configuration being empty without custom work-queues for the corresponding custom process templates existing in our docbase?
    The workflow type is kicked off based on the docid being the parameter or the argument but when I checked the logs bpm.log ,JMS logs and Tomcat->Documentum.log, the document id not found or doesn't exist in our docbase is the error/exception thrown.?

    Kindly throw some light DCTM_GURU, to fix our high impact New Dev env upgrade issue while integrating with custom inhouse web application our end.?

Sign In or Register to comment.