Home General

Problem in a query in OpenText Team Developer

Good afternoon everyone. First I want to apologize since I don't know if this is the right place to ask this question. But I couldn't find another place to do it. In the good old days of Centura Team Developer it was easier.

I am testing OpenText 7.3. I have not had any serious migration problem from CTD 6.2 but when I run the program and make a SqlPrepareAndExecute () statement looking for a data of type string, the data comes in an unintelligible language.

Example:

SELECT
razon_social, cuit
FROM
empresa
INTO
:sRazonSocial, :sCuit

String :sCuit containing numbers ('20115750690')
String :sRazonSocial contains the company name ('My company')

But when the SqlFetchNext() of the statement is executed the value in :sRazonSocial = "䕁佒䱃䉕唠䡓䅕䅉"

This occurs within a function that is used to validate the application.

In another application, I do the same query in a DialogBox but I bring the field razon:social to a DataField type and the query does not present any problem.

dfRazonSocial = 'My company'

I have running a SQLBase 11.6.2 (dbntsrv.exe)

Do I have to configure something special in OpenText Team Developer (x64) 7.3?

From now on, I thank you very much for your collaboration. They have always been very kind to me.

regards
Carlos Maida

Comments

  • I apologize. OpenText Team Developer 7.3 has nothing to do with this problem. It is not a program error.
    This is a problem in the method of loading a binary data using an external library.
    Actually this development version is much faster than anything known and its sharing is great.
    Also, many thanks to all who have patiently read my problem.

  • There seems to be a problem with the SqlSetLongBindDatatype (1, 23) statement since I can retrieve the binary field but the format is maintained in the next statement, retrieving the fields as binary data and not as text fields. This is solved if after executing the COMMIT of the SELECT SqlSetLongBindDatatype (1, 22) is executed.
    This contradicts what the TD Connecting SQLWindows Objects to Databases.pdf specifies:
    "SqlSetLongBindDatatype should be called immediately after the call to SqlPrepare. The binding established with SqlSetLongBindDatatype lasts until the next call to SqlPrepare on the same SQL handle."

  • Karen WeirKaren Weir Moderator EM admin
    Hi there,

    Could you please confirm if your post is about the OpenText TeamSite solution?  If so, I can move it to the developer network area where other experts are collaborating on the product.

    Karen


    Karen Weir
    Forum Moderator
    OpenText

  • Yes Karen. The post is about the new version of Centura Team Developer or OpenText 7.3

    Thanks very much

    Carlos
  • Karen WeirKaren Weir Moderator EM admin
    Thank you Carlos.
    Please complete this form to update your account to include "My Support".  Once our support team completes your account update, you will then have access to our Gupta Team Developer forum area where we have experts ready to help.
    https://forums.opentext.com/forums/support/categories/ot-gupta

    Karen


    Karen Weir
    Forum Moderator
    OpenText

This discussion has been closed.