Discussions
Categories
Groups
Community Home
Categories
INTERNAL ENABLEMENT
POPULAR
PUBLIC CLOUD
PRIVATE CLOUD
Quick Links
MY LINKS
HELPFUL TIPS
Back to website
Home
Content Management (Extended ECM)
API, SDK, REST and Web Services
Error fetching record
Carole_Rothman
Assuming that all attributes and tables are the same, is there a reason why a LiveReport that runs successfully in our development database would not run in the production database? The error message is: Livelink Error: Error processing request. [Error fetching record.]
Find more posts tagged with
Comments
Appu_Nair
The first way of debugging this is to take the SQL and using a editor such as TOAD run the query in your prod database.If it runs in production then maybe livelink is having a problem.What I mean is LL is just executing RAW SQL and returning results whatever you set up in the report interface.You say assuming "all attributes and tables are the same" this is very vague,this would either mean that your prod and dev are clones of the same database and has EFS also replicated.Is that really true.Otherwise llattrdata may have different defid's to go with unless you are filtering it by name.Could you post the query so that the community can see if it has hard coded data ?
Carole_Rothman
This is the query:select a.dataid, a.subtype, a.name, b.valstr "Purge Flag" from dtree a, llattrdata b where (a.dataid=b.id and b.attrid=11 and b.defid=33730 and b.valstr=1) order by b.valstrThe defid and attrid are the same in both development and production.
Appu_Nair
The query looks fine to me so long as the assumptions are the same.Th error fetching record is basically because livelink is not able to do a cursor execute with the sql statement.You can find that error string in Report:ExecuteReport.I suggest you open a ticket with OT support unless somebody else in this community has some other ideas to check for.Say it could not be something like you have attrid=11 as a string in dev and in production it now is a real flag like valint perhaps just a wild thought...
Appu_Nair
I searched for that error string in builder if you don't know it you cannot see it nor is it going to help debug the process.I did not want this to sound very authoritative here.This is a simple query does it run in your prod setting fine thru another tool.
Carole_Rothman
If I add AND a.parentid in (select z.dataid from dtree z where z.subtype = 0 start with z.dataid = 66653 connect by prior z.dataid = z.parentid)where z.dataid is any folder below enterprise, the query runs.Using z.dataid = 2000 which is the entire Enterprise container, the query fails with the same error message, "Error fetching record."There seems to be a limitation on running a query such as this from Enterprise in production and not in development.
Appu_Nair
your and is saying give me folders that start with dataid 66653 so basically it is just a recursive loop on that hierarchy.I am not sure if that has anything to do with the original problem.Regarding enterprise workspace always having 2000 that is a misconcept.Some enterprise workspaces have different numbers.You have to run this to find the dataid for your enterprise workspace.select dataid,parentid from dtree where subtype=141that dataid is usally 2000 or 2001