Stuck on Hierarchy Report *Help Please*

sdlemastersdlemaster Junior Member
I am an experienced BIRT developer and am absolutely stuck on this report. It works great in eclipse 2.3.2 against Maximo 7.5 database. It gives me up to 9 levels of asset subassembly parent to child relationship hierarchies. When I run it in Maximo it only gives the first two records and then stops. It will not continue executing the next data set. I created the report two different ways to try and make it work but both give the same results. Works in eclipse when previewed in Web Viewer but not in Maximo. I have tried everything and truly am stuck so looking for any assistance. Both rptdesigns are attached so feel free. All you need is a Maximo 7.5 to work against (7.1 might work too). Also both reports are DEBUG enabled so it will give you a log file with the SQL under your C:\TEMP directory locally and on Maximo it will be in your SystemOut.log file. Feel free to ask any questions. Thanks.

Comments

  • edited August 2012
    Instead of nested tables why not use one query with outer joins?

    Also, some databases (Oracle I know for sure), have a syntax for recursive queries.
  • sdlemastersdlemaster Junior Member
    edited December 1969
    I used the out-of-box /WOTRACK/workorder_hierarchy.rptdesign as a template and it uses nested tables so it made sense to just copy that and modify it to make it work with assets.

    My report with two data sets should work fine in Maximo. I created the second report with 9 data sets just to see if it would make a difference which it did not.

    If you compare the two log files that get generated (one in Maximo, one locally) the main difference is that the local log file opens and closes the subDataSet many times like it should and when you run the same report with same parameters in Maximo the log file shows that it only opens and closes the subDataSet twice.

    Let me know if you need me two attach the two different log files and highlight what I am talking about? Thanks.
  • sdlemastersdlemaster Junior Member
    edited December 1969
    anymore ideas out there?
  • edited December 1969
    Not from me. It it works in the designer it is not a BIRT issue. I would work on changing the query.
  • wwilliamswwilliams Junior Member
    edited December 1969
    I would put the sqlText in the header and run within Maximo so you can copy and paste the SQL into a sql tool and run.
    I'd also run it from the preview tab and see if it shows any problems.
  • wwilliamswwilliams Junior Member
    edited December 1969
    I would put the sqlText in the header and run within Maximo so you can copy and paste the SQL into a sql tool and run.
    I'd also run it from the preview tab and see if it shows any problems.
  • Did this report work for anybody with a parent location as parameter?

Sign In or Register to comment.