Maximo 7.6 and BIRT 4.3.1

Hello All,

I am running the BIRT report from inside Maximo and getting following errors. I don't get this error when I run the report from designer and the error is received only when I run the report from inside Maximo. Just FYI, report has all the features which is chart, Crosstab, inner tables etc.
This error started coming out recently.

Comments

  • I searched and found one instance of the same question being asked, but unfortunately the solution was not posted. The report in the other post used a scripted data set. Does your report also use a scripted Data Set? If so, maybe adding code to check for null values would eliminate the error. For example:

    Change:
    row["workorderid"] = DataSet.getString("workerid");

    To:
    var wid = DataSet.getString("workerid");
    if (wid == null) wid = "";
    row["workorderid"] = wid;

    Jeff F.
    Customer Support Engineer I
    OpenText
  • Thank you for your response. I am using scripted data source.
    Workorderid is an autonumber column in the table and by no means it can be null. Just for your confirmation i checked and it is never null

  • wwilliamswwilliams Junior Member

    You say it started recently, so if it was working in Maximo, what changed? I am guessing there is a data issue, I'd breakdown the report in smaller pieces and see if you can find the issue. Good Luck!

  • In addition to the questions from wwilliams, does your version of Maximo support the version of BIRT you are running?

    Jeff F.
    Customer Support Engineer I
    OpenText
  • wwilliamswwilliams Junior Member
    That is the correct version
  • The thread was open in my browser. I re-read the original post but did not scroll all the way to the top to see that the version information was provided in the main subject line. Thanks for the heads up.

    Jeff F.
    Customer Support Engineer I
    OpenText
  • Thank you for the thoughts!!!
    FYI, I changed the data type of workorderid from Integer to Decimal thinking it could be some thing related to Overflow. The error for Workorderid is gone and the same error is replaced by siteid. I mean siteid has replaced the workorderid and the rest remains the same.
    As W Williams suggested, I am going to break the report into pieces and try the error from there but it will take time as the report is so complex.
    Just a quick question, has alias in the query something to do with this?

    Thanks
    Vineet Joshi

  • wwilliamswwilliams Junior Member

    yes an alias may work in eclipse and can fail when registered in Maximo. I have used this for example
    var myWhere = params["where"].replace("matrectrans","m"); where m of course is my alias

Sign In or Register to comment.